Browse Site by Tags

Showing related tags and posts accross the entire site.
  • Help, can't sign in anymore with Avid link, although activated

    In the middle of my annual sub for Media composer. Mid project. On version 2018 12 9 I've updated Avid link. The Avid link page shows that I am indeed activated, but has an orange button suggesting that I update MC. I want to remain on my current version. Is this stopping me signing in now?
    Posted to Get Started Fast (Forum) by David G Hill on Sat, Jun 13 2020
  • Change license how to?

    Hi, my first post was in german, but Florian reminds me, that this is an english forum. What a big start! Here the same question, now in english (with accent). I wonder how I can change my annual subscription (until April 2016) into a new annual subscription with the 40% holiday-offer ($29,99)? I don´t...
    Posted to Licensing Options (Forum) by RobertBe on Sun, Dec 20 2015
  • Ilok issue

    I have an Avid MC 8.3 subscription license, so no dongle. At first Avid MC worked fine but now every time I start up MC it says I have to run Ilok first. I had never even heard of Ilok since Avid MC 8.3 started up fine. I now have Ilok installed and have created an account and now every time I run Ilok...
    Posted to Licensing Options (Forum) by Camiel Ledderhof on Sun, Apr 19 2015
  • Application Manager Startup Issue - fails to launch

    Hello, Today i booted up my Avid and the I recieved an application error saying the following. "There was an error initialzing the licensing engine. If you have migrated data from a different Machine please delete folder: C:programData\Avid\ Licences" Application can't continue work and...
    Posted to Licensing Options (Forum) by Felix450 on Tue, Dec 16 2014
  • Pro Tools Express registration / download impossible!

    Hi there, I have bought Avid Mbox with Pro Tools Express. I'm trying despirately to register and download Pro Tools, but after i fill in my iLok username (ID) and press continue, I am being referred to a blank page! I'm trying to find a way to send Avid and e-mail but apparently that is impossible...
    Posted to General Discussion & Off-Topic (Forum) by Hiltjo on Wed, Oct 2 2013
  • Lost Yellow Registration Card

    I don't know if this has already been alked on yet or not, but it seems that I have lost the yellow registration card from the Pro Tools 10 box. I know I'm stupid. I can't even recall seeing it, but i couldn't go but so far without it and a registration page kept coming up talking about...
    Posted to Community Issues and Suggestions (Forum) by brespree23 on Wed, Jan 9 2013
  • dongle to serial ?

    Hi, I work on an Avid MC5 with a laptop, with a dongle. I'm afraid to loose it cos i'm travelling a lot. is it a way to register my software or something like that to do not use my dongle anymore ? Sorry for my english.. i'm french. Thanks for replies. Karim.
    Posted to Avid Media Composer - PC (Forum) by Karim on Sun, Feb 20 2011
  • registered or Not?

    Hello. I'm new to Avid Media Composer 4 or anything else Avid to be frank. Recently, I purchased and installed Media Composer 4 with a minimum degree of installation difficulty. After dealing with the audio driver hiccup, things went well until registration of the software. First the software requested...
    Posted to Avid Media Composer - PC (Forum) by Sagerman on Sat, Mar 13 2010
  • Registered but worried about scams anyway

    Evening - It was probably a terrible idea, but after a fair bit of correspondance with a seller, I recently ordered a copy of xpress off of ebay. I registered the software through the avid website, dongle plugged in, with no problem. Got a confirmation email and all. A paranoid friend of mine got me...
    Posted to General Discussion & Off-Topic (Forum) by dillis on Sat, Mar 6 2010
  • Avid Registration

    Hey, I got Avid a few months ago, and registered it online. Then the other day I got a sound card for my computer, and opened Avid and it asked me to register it, again. I went online, and it said I had already used my 1 registration for it. But it's the same computer, I just put a sound card in...
    Posted to Avid Media Composer - PC (Forum) by BrittaGL on Thu, Oct 29 2009
Page 1 of 2 (16 items) 1 2 Next >

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller