Latest post Tue, Oct 5 2021 3:41 PM by Vshevchenko. 0 replies.
Page 1 of 1 (1 items)
Sort Posts: Previous Next
  • Tue, Oct 5 2021 3:41 PM

    [Webservice API] SendToPlayback fails with the error

    Hi.
    We are trying to use the SendToPlayback function from Avid Interplay WS 2018.9.1.
    First, we call ListTransferEngines, then GetTransferDevices for "interplay-itv1" and then SendToPlayback with the corresponding parameters.
    But SendToPlayback fails with the error "An unexpected error occurred when send a asset to playback from transfer engine interplay-itv1 for interplay-itv1: 6534 / SND_TO_ARCHIVE type"
    Please, see listing below.
    Could you please help us fix current issue.
    Thank you in advance,
    Valerii.

    ListTransferEngines
    interplay-itv2
    avid-as-1
    avid-as-2
    avid-as[2]
    interplay-itv1
     
    GetTransferDevices for "interplay-itv1"
    Playback: FTP
    Playback: SND_TO_ARCHIVE
     
    SendToPlayback
    <?xml version="1.0"?>
    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <SOAP-ENV:Header>
        <NS1:UserCredentials xmlns:NS1="http://avid.com/interplay/ws/assets/types">
          <Username xmlns="http://avid.com/interplay/ws/assets/types">*****</Username>
          <Password xmlns="http://avid.com/interplay/ws/assets/types">*********</Password>
        </NS1:UserCredentials>
      </SOAP-ENV:Header>
      <SOAP-ENV:Body>
        <SendToPlayback xmlns="http://avid.com/interplay/ws/transfer/types">
          <TransferEngineHostName>interplay-itv1</TransferEngineHostName>
          <InterplayURI>interplay://AvidWG?mobid=060a2b340101010101010f0013-000000-0d241b00340900fa-060e2b347f7f-d080</InterplayURI>
          <DestinationPlaybackDevice>interplay-itv1:6534/SND_TO_ARCHIVE</DestinationPlaybackDevice>
          <Priority>NORMAL</Priority>
          <Overwrite>true</Overwrite>
        </SendToPlayback>
      </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>
     
    <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
      <soap:Body>
        <SendToPlaybackResponse xmlns="http://avid.com/interplay/ws/transfer/types" xmlns:ns2="http://avid.com/interplay/ws/assets/types">
          <Errors>
            <ns2:Error Code="OTHER_ERROR">
              <ns2:Message>An uncategorized error has occurred</ns2:Message>
              <ns2:Details>An unexpected error occurred when send a asset to playback from transfer engine interplay-itv1 for interplay-itv1:6534/SND_TO_ARCHIVE type.</ns2:Details>
            </ns2:Error>
          </Errors>
        </SendToPlaybackResponse>
      </soap:Body>
    </soap:Envelope>
Page 1 of 1 (1 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller