Latest post Fri, Jan 8 2021 11:27 PM by camoscato. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • Fri, Jan 8 2021 10:47 PM

    • Jim
    • Not Ranked
    • Joined on Fri, Apr 1 2011
    • Malmstrom
    • Posts 116
    • Points 1,465

    ACTIVATION

    I have downloaded MC 8.4.4 onto a new PC from the 'MY PRODUCTS' area of account profile.  I see my system ID and I see an activation code.

    Problem is i get no opportunity to enter either one.  We don't have hardware/USB Dongle and it's not a trial so I choose ELECTRONIC ACTIVATION and click CONTINUE but nothing happens.

    Anybody have an idea?   Would appreciate help.  Thank You

     

    Jim

     

     

    HP Pav i7-970 3.2GHz 24GB DDR3 RAM Quadro 2000D 1GB GDDR3 Quicktime 7.6.9 [view my complete system specs]
  • Fri, Jan 8 2021 11:27 PM In reply to

    Re: ACTIVATION

    Is the Avid Link application installed on the system? Can you activate using that?

    Media Composer 2024.6 w/Symphony/SS/PF options, HP Z-Book G6 17", i7-9850H 2.60GHz, 64gb RAM, NVIDIA Quadro RTX 3000, Blackmagic UltraStudio Mini... [view my complete system specs]

    "There is hardly anything in the world that some man cannot make a little worse and sell a little cheaper, and the people who only consider the price are this man's lawful prey."  - John Ruskin (1819-1900)

     

    Carl Amoscato | Freelance Film & Video Editor | London, UK

Page 1 of 1 (2 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller