Latest post Wed, Jun 10 2015 2:14 PM by robg. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • Wed, Jun 3 2015 6:44 PM

    • Nick Ridley
    • Not Ranked
    • Joined on Mon, Aug 4 2014
    • London
    • Posts 10
    • Points 110

    JFIF encoding issues with AMT 2.11

    Hello,

    Something we are struggling with having now updated to SDK 2.11 from 2.10 is that we get an error message when encoding any JFIF resolutions. These worked just fine in SDK 2.10. It appears to work in SDK 2.12 which implies something has been fixed, but SDK 2.12 drops encoding of some formats so using that is not ideal.

    Specifically when we call

    CreateAmtFile using a destination directory, the input and output xml as specified in the spreadsheet (e.g. UNC_720_248_NTSC_2A.XML and JFIF_20_1_NTSC_2A.XML) and NULL and NULL as the final two parameters

    we get AMT_COMPRESSION_FORMAT_NOT_SUPPORTED

    If I revert the DLLs to those for SDK 2.10 we get an OK status returned instead.

     

    As far as I can tell nothing has changed in the XML examples for the JFIF resolutions between these versions so I am mystified. The release notes for 2.11 suggest some tweaks to JFIF encoding but nothing is reflected in the example XML files so I can only assume that's internal fixes that don't concern an end user.

     

    This call is ahead of transmission of any actual video and audio data. I've tried using the RAW_TO_AMT feature of the sample application with the same output XML file and that appears to run so perhaps a change has been made to what the JFIF codecs require as an input format and the spreadsheet has not been updated?

     

    We're using the VC10x86 SDK. Any help would be gratefully received - is it just that JFIF encoding is busted in 2.11 or is there something I can do to make it work?

    Thanks

    Nick

    Filed under: ,
  • Tue, Jun 9 2015 7:07 PM In reply to

    • robg
    • Top 500 Contributor
    • Joined on Fri, Nov 4 2005
    • Tewksbury, MA
    • Posts 494
    • Points 5,625
    • ! Avid Employee
      Avid Developer Moderator

    Re: JFIF encoding issues with AMT 2.11

    Nick,

    Sorry for the delay. We are looking at this now...

    - Rob

     

  • Wed, Jun 10 2015 2:14 PM In reply to

    • robg
    • Top 500 Contributor
    • Joined on Fri, Nov 4 2005
    • Tewksbury, MA
    • Posts 494
    • Points 5,625
    • ! Avid Employee
      Avid Developer Moderator

    Re: JFIF encoding issues with AMT 2.11

    Nick,

    I checked with our support team. 

    They confirmed that there was a change in AMT 2.11 that affected JFIF encoding. And this was fixed in AMT 2.12.

    - Rob

     

Page 1 of 1 (3 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller