Latest post Sat, Jan 28 2023 3:52 AM by Robert Martindale. 21 replies.
Page 1 of 2 (22 items) 1 2 Next >
Sort Posts: Previous Next
  • Mon, Jan 9 2023 9:41 AM

    • mtahir
    • Top 200 Contributor
    • Joined on Thu, Oct 13 2005
    • UK
    • Posts 561
    • Points 6,885

    Blackmagic Desktop Video and MC menu problem

    If I use Blackmagic Desktop Video v12.4.2 with MC2022.12 and an Intensity Pro 4K card, I get this problem:

    HW/SW -> INTENSITY PRO 4K -> CONFIGURE (Nothing happens)
    SETTINGS -> PROJECT -> VIDEO OUTPUT -> MORE (Nothing happens)

    Roll back to Blackmagic Desktop Video v11.6 and everything works as it should i.e. the Blackmagic Desktop Video Setup control panel appears.

    I was using Desktop Video v11.6 with MC2022.7 and it was all fine. I didn't try MC2022.7 with a later version of Desktop Video, so I don't know whether it's an issue with MC or Blackmagic.

    MC2022.12 (Win10) | DaVinci Resolve Studio | Dell T7500 with 2 x 6-Core Intel Xeon X5690 3.46GHz CPUs | Triple-Channel 96GB (48GB per CPU) 1333MHz DDR3... [view my complete system specs]
  • Tue, Jan 10 2023 9:26 AM In reply to

    • Mercer
    • Top 150 Contributor
    • Joined on Thu, Apr 15 2010
    • UK
    • Posts 873
    • Points 11,290

    Re: Blackmagic Desktop Video and MC menu problem

    Hi Mtahir, if you look in C:\Program Files\Blackmagic Design\ you may have 2 folders: 1, Desktop Video and the other Blackmagic Desktop video. Within either there should be another folder, Avid Support. And yet again, with that folder should be OpenIO_Blackmagic.acf. Make sure this file is in your AVX2 top folder. 12.4.2 was meant to correct this, since 12.4.1 created 'Blackmagic Desktop Folder' and Avid was unable to find the interface or use the BMD device. I deleted this folder when I installed 12.4.2.

    MC with Symphony option, 2022.10, HP ZBook 17 G5, i7-8850H 6 core/64GB ram/512 M2 ssd/Nvidia Quadro P5200/16GB/FHD, HP Thunderbolt Dock G2, BMD Ultrastudio... [view my complete system specs]
  • Wed, Jan 11 2023 12:14 AM In reply to

    Re: Blackmagic Desktop Video and MC menu problem

    FWIW With a Widows 10 computer here the last BM Desktop Video I installed was in July 2019.  All the MC versions from that date forward including 2022.12 have just worked as expected. I have not had any isues with BM hardware or software either.   

    There is a possibility that creating a new user settings in MC might affect the setup. I have not created new user settings here since well before 07 2019. 

  • Thu, Jan 12 2023 10:55 PM In reply to

    • mtahir
    • Top 200 Contributor
    • Joined on Thu, Oct 13 2005
    • UK
    • Posts 561
    • Points 6,885

    Re: Blackmagic Desktop Video and MC menu problem

    Mercer:

    Hi Mtahir, if you look in C:\Program Files\Blackmagic Design\ you may have 2 folders: 1, Desktop Video and the other Blackmagic Desktop video. Within either there should be another folder, Avid Support. And yet again, with that folder should be OpenIO_Blackmagic.acf. Make sure this file is in your AVX2 top folder. 12.4.2 was meant to correct this, since 12.4.1 created 'Blackmagic Desktop Folder' and Avid was unable to find the interface or use the BMD device. I deleted this folder when I installed 12.4.2.

    Spot on with the folder renaming!

    The 'OpenIO_Blackmagic.acf' is in the right place, however, it's the renaming of 'Desktop Video' -> 'Blackmagic Desktop Video' by Blackmagic that causes the problem. Put that back to 'Desktop Video' and it starts to work.

    In my case, with v11.6, I have the 'Desktop Video' folder in there. Install v12.4.2 and it deletes 'Desktop Video' and gives you 'Blackmagic Desktop Video' which then causes the issue.

    I'm not sure who needs to make the change i.e. Avid or Blackmagic. I suppose it depends on if Blackmagic have decided to keep the new name for the folder.

    MC2022.12 (Win10) | DaVinci Resolve Studio | Dell T7500 with 2 x 6-Core Intel Xeon X5690 3.46GHz CPUs | Triple-Channel 96GB (48GB per CPU) 1333MHz DDR3... [view my complete system specs]
  • Thu, Jan 12 2023 10:59 PM In reply to

    • mtahir
    • Top 200 Contributor
    • Joined on Thu, Oct 13 2005
    • UK
    • Posts 561
    • Points 6,885

    Re: Blackmagic Desktop Video and MC menu problem

    AndrewAction:

    FWIW With a Widows 10 computer here the last BM Desktop Video I installed was in July 2019.  All the MC versions from that date forward including 2022.12 have just worked as expected. I have not had any isues with BM hardware or software either.   

    There is a possibility that creating a new user settings in MC might affect the setup. I have not created new user settings here since well before 07 2019. 

    I'm like you in that I haven't really changed my MC settings for a while. But as Mercer has pointed out, it's the renaming of a folder by Blackmagic in the latest versions of their Desktop Video app that causes the issue.

    MC2022.12 (Win10) | DaVinci Resolve Studio | Dell T7500 with 2 x 6-Core Intel Xeon X5690 3.46GHz CPUs | Triple-Channel 96GB (48GB per CPU) 1333MHz DDR3... [view my complete system specs]
  • Sat, Jan 14 2023 10:42 AM In reply to

    • Mercer
    • Top 150 Contributor
    • Joined on Thu, Apr 15 2010
    • UK
    • Posts 873
    • Points 11,290

    Re: Blackmagic Desktop Video and MC menu problem

    mtahir:
    But as Mercer has pointed out, it's the renaming of a folder by Blackmagic in the latest versions of their Desktop Video app that causes the issue.

    12.4.2. has not solved the issue, since it still creates a Blackmagic Desktop Video folder, contrary to what BMD say. Reverting to 12.4, resolves the issue. Deinstall later drivers and delte any DV folders first.

    MC with Symphony option, 2022.10, HP ZBook 17 G5, i7-8850H 6 core/64GB ram/512 M2 ssd/Nvidia Quadro P5200/16GB/FHD, HP Thunderbolt Dock G2, BMD Ultrastudio... [view my complete system specs]
  • Sun, Jan 15 2023 9:59 PM In reply to

    • mtahir
    • Top 200 Contributor
    • Joined on Thu, Oct 13 2005
    • UK
    • Posts 561
    • Points 6,885

    Re: Blackmagic Desktop Video and MC menu problem

    Mercer:

    12.4.2. has not solved the issue, since it still creates a Blackmagic Desktop Video folder, contrary to what BMD say. Reverting to 12.4, resolves the issue. Deinstall later drivers and delte any DV folders first.

    I'm using 12.4.2. I create a soft link called 'Desktop Video' which links to 'Blackmagic Desktop Video' folder that gets around the problem.

    MC2022.12 (Win10) | DaVinci Resolve Studio | Dell T7500 with 2 x 6-Core Intel Xeon X5690 3.46GHz CPUs | Triple-Channel 96GB (48GB per CPU) 1333MHz DDR3... [view my complete system specs]
  • Mon, Jan 16 2023 6:27 PM In reply to

    • Steve Sidoruk
    • Not Ranked
    • Joined on Fri, Nov 4 2005
    • Harwich, MA USA
    • Posts 71
    • Points 1,100

    Re: Blackmagic Desktop Video and MC menu problem

    I'm so happy to find this post, as I have been dealing with the same problem.

    Had multiple software installs/uninstalls attempting to get systems to work properly.  I'll now

    get software back and apply the fix.  Thanks for the help!

    MC 2022.12; Win10PRO; 64-bit Intel MoBo DX58SO2 Extreme Series; Intel Core i7 CPU, 3.07 GHz; 32 GB RAM; NVIDIA QUADRO FX 1700, PCIE; Readyboost 16 GB ... [view my complete system specs]
  • Fri, Jan 20 2023 7:27 AM In reply to

    • Mercer
    • Top 150 Contributor
    • Joined on Thu, Apr 15 2010
    • UK
    • Posts 873
    • Points 11,290

    Re: Blackmagic Desktop Video and MC menu problem

    mtahir:
    I'm using 12.4.2. I create a soft link called 'Desktop Video' which links to 'Blackmagic Desktop Video' folder that gets around the problem.

    What is the 'soft link' trick you used, Mtahir?

    MC with Symphony option, 2022.10, HP ZBook 17 G5, i7-8850H 6 core/64GB ram/512 M2 ssd/Nvidia Quadro P5200/16GB/FHD, HP Thunderbolt Dock G2, BMD Ultrastudio... [view my complete system specs]
  • Fri, Jan 20 2023 12:15 PM In reply to

    • mtahir
    • Top 200 Contributor
    • Joined on Thu, Oct 13 2005
    • UK
    • Posts 561
    • Points 6,885

    Re: Blackmagic Desktop Video and MC menu problem

    Mercer:

    What is the 'soft link' trick you used, Mtahir?

    Go to this site and download 'Link Shell Extension': https://schinagl.priv.at/nt/hardlinkshellext/linkshellextension.html

    Once installed, it should appear in your context menu (right click).

    1. Go to 'C:\Program Files\Blackmagic Design'

    2. Select 'Blackmagic Desktop Video'

    3. Right click -> Pick Link Source

    4. Click anywhere in the Explorer window, right click and select: 'Drop As... Symbolic Link'. You should see: 'Blackmagic Desktop Video - SymbolicLink' in your  'C:\Program Files\Blackmagic Design' folder.

    5. Rename 'Blackmagic Desktop Video - SymbolicLink' to 'Desktop Video'. Push into 'Desktop Video' and you should see the contents of 'Blackmagic Desktop Video'. Deleting the symbolic link won't delete the contents of the source folder, in this case, 'Blackmagic Desktop Video'.

    I use this with the 'Avid MediaFiles' folder too. I create one, say, on the top level of drive 'MEDIA1'. My projects can be anwhere on the drive. All I do is create symbolic links from the '1' in my project to a '1' in the 'Avid MediaFiles' folder on MEDIA1, and so on for other projects. I tend to have a project folder with all my files in it and I just use symbolic links to link out the actual media that MC is looking for.

    I hope that helps.

     

    MC2022.12 (Win10) | DaVinci Resolve Studio | Dell T7500 with 2 x 6-Core Intel Xeon X5690 3.46GHz CPUs | Triple-Channel 96GB (48GB per CPU) 1333MHz DDR3... [view my complete system specs]
  • Sat, Jan 21 2023 12:52 PM In reply to

    • Mercer
    • Top 150 Contributor
    • Joined on Thu, Apr 15 2010
    • UK
    • Posts 873
    • Points 11,290

    Re: Blackmagic Desktop Video and MC menu problem

    Thanks Mtahir, useful to know but I think I will stick with 12.4 for now, since there is nothing that later versions add to my BMD device.

    MC with Symphony option, 2022.10, HP ZBook 17 G5, i7-8850H 6 core/64GB ram/512 M2 ssd/Nvidia Quadro P5200/16GB/FHD, HP Thunderbolt Dock G2, BMD Ultrastudio... [view my complete system specs]
  • Sat, Jan 21 2023 2:33 PM In reply to

    • mtahir
    • Top 200 Contributor
    • Joined on Thu, Oct 13 2005
    • UK
    • Posts 561
    • Points 6,885

    Re: Blackmagic Desktop Video and MC menu problem

    Mercer:

    Thanks Mtahir, useful to know but I think I will stick with 12.4 for now, since there is nothing that later versions add to my BMD device.

    No problem. :)

    MC2022.12 (Win10) | DaVinci Resolve Studio | Dell T7500 with 2 x 6-Core Intel Xeon X5690 3.46GHz CPUs | Triple-Channel 96GB (48GB per CPU) 1333MHz DDR3... [view my complete system specs]
  • Wed, Jan 25 2023 7:54 AM In reply to

    Re: Blackmagic Desktop Video and MC menu problem

    ...no joy....following the cookbook exactly....not sure what happens next...BM and AVID need to talk...lots of people use this hardware.

    I9-NVidia3060-160ram-WIN11PRO-MC23.12-NewBlueFX-Photoshop-Shutter Encoder-Boris Continuum 12.5-VLC Player [view my complete system specs]
  • Wed, Jan 25 2023 10:11 AM In reply to

    Re: Blackmagic Desktop Video and MC menu problem

    I can give more details in a couple of days but quick overview is that after installing an update to an installed older version of MC I lost the video output of my BM intensity Pro 4K. Audio still went through the Intensity pro as normal.

    I moved the file as Mercer suggested but nothing changed UNTIL I restarted MC. Then everything returned to working normally.

  • Wed, Jan 25 2023 12:35 PM In reply to

    • Mercer
    • Top 150 Contributor
    • Joined on Thu, Apr 15 2010
    • UK
    • Posts 873
    • Points 11,290

    Re: Blackmagic Desktop Video and MC menu problem

    AndrewAction:
    I moved the file as Mercer suggested but nothing changed UNTIL I restarted MC. Then everything returned to working normally.

    Just to clarify, Andrew. My intial advice was wrong. BMD stated that 12.4.2 has corrected the error of 12.4.1 for both Avid and Premiere. This is not the case as I discovered, at least for Avid - 12.4.2 still creates a Blackmagic Desktop Video folder, which means that although the I/O is now recognised, Avid can't access the Hardware panel from within Avid. Reverting to 12.4 (after deleting the new folder) solves the issue and in my case and most of the current devices loses no added functionality, since there doesn't appear to be any. What I can't remember is re booting after installing 12.4.2, though I know you should, so perhaps when you get a chance, you can confirm whether the Hardware panel appears for you?

    MC with Symphony option, 2022.10, HP ZBook 17 G5, i7-8850H 6 core/64GB ram/512 M2 ssd/Nvidia Quadro P5200/16GB/FHD, HP Thunderbolt Dock G2, BMD Ultrastudio... [view my complete system specs]
Page 1 of 2 (22 items) 1 2 Next >

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller