Latest post Tue, Mar 2 2021 7:30 PM by Vadym. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • Wed, Nov 18 2020 9:49 AM

    • yoruba
    • Not Ranked
    • Joined on Wed, Jun 15 2016
    • The Netherlands
    • Posts 37
    • Points 360

    Internal error during pa:mediaInfoBulk

    I get a error during pa:mediaInfoBulk.

    curl --location --request POST 'https://upstream/apis/avid.pam.mediainfo;version=1;realm=ABC/mediaInfo/bulk/' \

    --header 'Authorization: Bearer ABC' \ --header 'Content-Type: application/json' \ --data-raw '["060a2b340101010101010f0013-000000-091716006a7f00aa-060e2b347f7f-d080"]'

     

    { "code": "avid.acs/I0002", "params": {}, "message": "Internal service error", "incident": "d42974bf-b97e-444d-880c-90001360e366", "exchange": "2c4deff0-2980-11eb-9c2a-32bc8a811b84", "status": 500 }

     

    The none bulk function pa:mediaInfo-by-id is working fine. Thanks, Adri Vermeulen Yoruba, software development
  • Thu, Nov 19 2020 2:51 PM In reply to

    • yoruba
    • Not Ranked
    • Joined on Wed, Jun 15 2016
    • The Netherlands
    • Posts 37
    • Points 360

    Re: Internal error during pa:mediaInfoBulk

    Same with pa:mediainfo-command

    I think you have to call first pa:mediainfo-command to excecute the bulk command.

    And then later ask the status with pa:mediaInfoBulk

    More information how to use the functions provide with pa:extended would be helpfull for everyone.

    Some people doesn't even know that you can create a sequence with pa:extended.

    curl --location --request POST 'https://upstream/apis/avid.pam.mediainfo;version=1;realm=ABC/mediaInfo/bulk/command' \ --header 'Authorization: Bearer ABC' \ --header 'Content-Type: application/json' \ --data-raw '["060a2b340101010101010f0013-000000-0e2804006e5400ff-060e2b347f7f-d080"]'
  • Tue, Mar 2 2021 7:30 PM In reply to

    • Vadym
    • Top 500 Contributor
    • Joined on Thu, Apr 17 2014
    • Posts 262
    • Points 3,110
    • ! Avid Employee
      Avid Developer Moderator

    Re: Internal error during pa:mediaInfoBulk

    Hi Adri,

    We have looked into this error and it is caused by the incorrect message body.

    Unfortunately at the moment this API is not public. For more details please contact you Avid Partnerships & Alliances representative.

    Thanks,

    Vadym

Page 1 of 1 (3 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller