Latest post Tue, Oct 20 2020 4:37 PM by Pixel Monkey. 7 replies.
Page 1 of 1 (8 items)
Sort Posts: Previous Next
  • Sat, Oct 17 2020 10:18 PM

    • mlapoff
    • Not Ranked
    • Joined on Tue, May 22 2012
    • Posts 7
    • Points 105

    Mac OS version Compatible with MC 2020.8

    I'm done with paying Avid year after year after year after year. My Media Composer/Symphony support ransom just ended. The last version I "own" is 2020.8. I don't want to update my Mac anymore and I'll just use it as dedicated machine. Does anyone know if 2020.8 is compatible with OS 10.15.7? I have searched the website and forums for an answer with no success. I'm afraid if I ask AVID they will chrage me for he answer. I have literally spent 10's of thousands on Media Composer since 1995 and I've had enough of AVID's money grubbing. I'd appreciate an answer from someone. Thanks!

  • Sun, Oct 18 2020 8:42 AM In reply to

    Re: Mac OS version Compatible with MC 2020.8

    Well as somebody who has also paid for the development and support of the editing software that earnt me and my Post houses staffs wages I've also spent countless money on numerous licenses. As I also spend on my Adobe subscription. My Web hosting my email accounts. My mobile phone contracts and countless other costs. 

     

    It's around £1 per day to pay for Avid support. 

    I can't even park in town for an hour for that. 

     

     

    I guess if your work doesn't generate an income then spending on the software doesn't make sense. But even hobbies cost. 

     

    I can't imagine you think the software development and support is done for free by those employed by Avid. And even this forum is run by Avid. 

     

    You may want to try googling Avid OS compatability matrix for your answer. 

     

    I'd dig out the link myself but I'm less inclined to give up my time for free on a Sunday morning. 

    ACI Moderator. I'm not employed by Avid or work for them. I just do this in my spare time. Normally using the current Media Composer version on My... [view my complete system specs]

     

    Broadcast & Post Production Consultant / Trainer  Avid Certified Instructor VET

     

    QC/QAR Training - Understanding Digital Media - Advanced Files * Compression - Avid Ingest - PSE fixing courses and more

    All bespoke and delivered onsite at yours. Or delivered via hosted Zoom session.

     

    T 07581 201248 | E pat@vet-training.co.uk | W www.vet-training.co.uk |

     

  • Sun, Oct 18 2020 10:58 AM In reply to

    • Pixel Monkey
    • Top 100 Contributor
    • Joined on Thu, Oct 13 2005
    • Everywhere. Just like Avid ;)
    • Posts 1,262
    • Points 16,000
    • Moderator: Broadcast Newsroom
      Moderator: Media Composer Getting Started

    Re: Mac OS version Compatible with MC 2020.8

    Thanks, Pat. I can help Michael with the links he needs.

    Hi Michael. Yes MC2020.8 is compatible with macOS 10.15.7. Even if Apple released a 10.15.8, your copy of MC2020.8 would be compatible. Because of users feeling the strain from Apple to no longer have 32-bit apps as of Catalina, Avid decided to pre-qualify all versions of Catalina for all versions of Media Composer 2020.x.

    Here is the official Avid link to their "version matrix" that Pat mentioned: https://avid.secure.force.com/pkb/articles/en_US/compatibility/en267087

    I also have a few dozen pages on my own website that I dedicate to illustrating the various Avid versions, here: http://www.alwaysediting.com/avid-mc-versions.html

    On that site, here is a list of all their recent versions of MC: http://www.alwaysediting.com/mc-list.html

    ...And here is your specific version: http://www.alwaysediting.com/mc-2020.8.html

    Now... You'll notice that I listed MC2020.8 as having a maximum qualification of macOS 10.15.6. I lonly did so because MC2020.8 came out before ,acOS 10.15.7 did. However as I explained above, "technically" your MC2020.8 is pre-qualified by Avid for 10.15.7. So you won't have any issues. Especially since if you Google the release history for 10.15.7 (here), as well as many articles written about it, you'll see that it is actually Apple's frail attempt to patch-up some bugs they left unfinished in 10.15.6.

    Does that answer your questions?

    So yes, your idea of no longer paying Avid for its new software will work fine on that machine. I run many Avids, and two of them are "mothballed" like that as well. I have a Symphony 6.5 on Mountain Lion 10.8.4, and a Media Composer 2.6.1 Adrenaline on Windows XP. Keeping those alive has been working great, although of course it's best to do so with a dongle, because once Apple EOL's their macOS security updates (High Sierra is being killed in two weeks), they should no longer be on the internet or any network.

    PS -- That's the whole reason why we pay Avid service contracts. Apple kills each macOS after a few years. Avid on the other hand keeps updating it, and also keeps older versions seviceable. Nobody else does that. 

    ACA Leader__Avid Pro Vid Moderator__Specs? Many. All qualified. But I still do stupid things. :) [view my complete system specs]

    Editors are superheroes, cutting life together in a world that cuts itself apart.

     

    Chris Bove' (Pixel Monkey)

    Twitter: @heybove   Blog for Craft Editors

    WWLD (What Would Larry Do?)   WWND (What Would Norman Do?)   #AllisWell

  • Mon, Oct 19 2020 2:08 PM In reply to

    • Marianna
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Avid
    • Posts 11,380
    • Points 233,240
    • Avid Beta Moderators
      Avid Customer Advocate
      Avid Developer Moderator
      BlogAuthor
      SystemAdministrator

    Re: Mac OS version Compatible with MC 2020.8

    Michael,

    Im very sorry you feel that way.....knowing that since 1995 - MC has progressed and the more recent version 2020.4 and higher is in fact Catalina compatible.  

    As for compatibility Media Composer 2020.8 and 2020.9 are compatible with:

    Macintosh 10.13.6, 10.14.6, 10.15.6

    As for Avid's money grubbing, I think Pat put it perfectly in his response to you and I also add that software development and support IS NOT FREE and we spend countless hours and $ to improve th products you own. Sibelius, PT and MC.   You utilize support which is also a cost and while only a few posts on the forums, this too cost $.  

    Nothing is free in this world.... as someone always has to fund it somehow.

    Your choice to lapse the license but I would have thought a note to myself or Raff outlining your situation and if there was anything we could do to help with the service plan part would have been a better road to take.

    Im here on email if you need to engage.

    Marianna

    Director of CSM | Customer Advocate [view my complete system specs]
  • Mon, Oct 19 2020 5:58 PM In reply to

    • mlapoff
    • Not Ranked
    • Joined on Tue, May 22 2012
    • Posts 7
    • Points 105

    Re: Mac OS version Compatible with MC 2020.8

    I will reply to you by email. These forumns become uncomfortable places for public discussion.

  • Mon, Oct 19 2020 6:00 PM In reply to

    • mlapoff
    • Not Ranked
    • Joined on Tue, May 22 2012
    • Posts 7
    • Points 105

    Re: Mac OS version Compatible with MC 2020.8

    Pixel Monkey. Thank you so much for your gracious, kind and helpful answer to my question. I appreciate the civilty.

  • Mon, Oct 19 2020 6:12 PM In reply to

    • Marianna
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Avid
    • Posts 11,380
    • Points 233,240
    • Avid Beta Moderators
      Avid Customer Advocate
      Avid Developer Moderator
      BlogAuthor
      SystemAdministrator

    Re: Mac OS version Compatible with MC 2020.8

    mlapoff:

    I will reply to you by email. These forumns become uncomfortable places for public discussion.

    Great looking forward to helping.... Im standing by for it.

    Marianna

    Director of CSM | Customer Advocate [view my complete system specs]
  • Tue, Oct 20 2020 4:37 PM In reply to

    • Pixel Monkey
    • Top 100 Contributor
    • Joined on Thu, Oct 13 2005
    • Everywhere. Just like Avid ;)
    • Posts 1,262
    • Points 16,000
    • Moderator: Broadcast Newsroom
      Moderator: Media Composer Getting Started

    Re: Mac OS version Compatible with MC 2020.8

    Hey Michael... It looks like I'm going to reverse my position on this. Avid's support team is apparently getting a WHOLE lot of people complaining of tech issues with macOS 10.15.7. So for the time being, we're all going to start recommending that people stay on 10.15.6 or lesser. 

    Apple released 10.15.7 in a hurry to fix a massive bug in 10.15.6, and it looks like they overlooked a few things. So if it is possible for people to roll-back, even tro 10.15.5, then I'd say do that. If not, then they might simply have to deal with a few issues.

    The team is working on it. Stay tuned... 

    ACA Leader__Avid Pro Vid Moderator__Specs? Many. All qualified. But I still do stupid things. :) [view my complete system specs]

    Editors are superheroes, cutting life together in a world that cuts itself apart.

     

    Chris Bove' (Pixel Monkey)

    Twitter: @heybove   Blog for Craft Editors

    WWLD (What Would Larry Do?)   WWND (What Would Norman Do?)   #AllisWell

Page 1 of 1 (8 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller