Latest post Thu, Nov 14 2019 3:36 PM by hstadtmueller. 0 replies.
Page 1 of 1 (1 items)
Sort Posts: Previous Next
  • Thu, Nov 14 2019 3:36 PM

    How to interprete StatusInfo of Airspeed5000

    How is the behavior of the Status-Reply of the Airspeed5000

    While no clip is cued for playing I get the response

    <?xml version="1.0" encoding="utf-8"?><AMS><Reply Status="OK" /><StatusInfo Ctrl="IDLE" RecMode="false" Cued="0_0" Pos="00:00:00:00" iPos="0" />  <VidStandard>HD_1920x1080i_25_000</VidStandard></AMS>"

    with attributes: Ctrl, RecMode, Cued, Pos, iPos

     

    After cueing up a clip in the Avid-GUI I'm getting no more attribute named "Cued" but instead there is

    <?xml version="1.0" encoding="utf-8"?><AMS><Reply Status="OK" /><StatusInfo Ctrl="CUED" Active="0_3" RecMode="false"  Dur="00:00:00:24" iDur="24" Name="Ingest-5-3" Pos="00:00:00:00" iPos="0" />  <VidStandard>HD_1920x1080i_25_000</VidStandard>  <PlayList Name="4" ActivePos="-1" CuePos="2" Dur="04:04:35:19" iDur="366894" Pos="04:04:34:20" iPos="366870"  /></AMS>

    with attributes: Ctrl, Active, RecMode, Dur, iDur, Name, Pos, iPos

     

    From the protocol-description the handling of "Active" and "Cued" is not really clear to me:

    - The STRING attribute “Active” is the ID of the Active Clip. This attribute will not exist if there are nocurrently active clips.
    - The STRING attribute “Cued” is the ID of the Cued Clip. This attribute will not exist if no clip is currently cued

    What would I receive, if a clip is playing and the next is cued for playing?

    Some examples would be very helpful.

    Filed under:
Page 1 of 1 (1 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller