Latest post Tue, Oct 22 2019 5:35 PM by curiosity. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • Tue, Oct 22 2019 5:05 AM

    • curiosity
    • Top 150 Contributor
    • Joined on Thu, Oct 13 2005
    • Boulder, CO
    • Posts 836
    • Points 10,565

    Installer background image casues stall

    Anyone else noticing this?

    When I open an intsall dmg file (on Macintosh) the installer app icons show up and then I get a rainbow wheel for about 5 minutes while it does something (processes?) the background image of the installer.

    To be fair this isn't just an Avid thing, it seems to be doing this with a bunch of dmg installers, its just Avid's rainbow wheel is about 10x longer than any other installer.

    I have this problem on all 40 systems I manage including:

    • 2012, 2016, 2018 iMacs
    • 2016, 2018 Mac Pro
    • 2012, 2016, 2019 Macbook Pro

     

    Under everything from:

    • El Capitan (10.11) - Mojave (10.14)

    Most configured with
    • 32GB RAM
    • 2TB Hard Drive (Some Fusion some non)


    i7-5820(x99), 64GB, Win 8.1, GTX 1080ti [view my complete system specs]
  • Tue, Oct 22 2019 1:54 PM In reply to

    • RalphC
    • Top 50 Contributor
    • Joined on Wed, Sep 2 2015
    • Posts 2,157
    • Points 24,015
    • Avid Customer Advocate
      Avid Customer Service
      Avid Employee
      SystemAdministrator

    Re: Installer background image casues stall

    Can you try In finder, launch /System/Library/CoreServices/Installer.app. It will prompt you to locate a .pkg file to install. Navigate to the .dmg volume you've mounted, and select the AvidMediaComposer.pkg file.

    MacBook Pro 15 2018 Intel Core i7 2.6GHz Mac 10.13.6 Intel UHD 630. [view my complete system specs]
  • Tue, Oct 22 2019 2:39 PM In reply to

    • jcmcnamee
    • Top 500 Contributor
    • Joined on Thu, Oct 13 2005
    • Brooklyn, NY
    • Posts 280
    • Points 2,965

    Re: Installer background image casues stall

    I can't remember the last time this DIDN'T happen for me (pre 2018.12?). I've learned to just open the dmg and let it do its thing in the background until the image finally shows up and I can install. But I'm only managing one system...can't imagine going through this on 40!

    Media Composer 2020.6 / OS 10.15.5 27" iMac 5K 2017 [4.2 GHz Intel Core i7, 64 GB ram, Radeon Pro 580 8 GB] [view my complete system specs]
  • Tue, Oct 22 2019 4:37 PM In reply to

    • curiosity
    • Top 150 Contributor
    • Joined on Thu, Oct 13 2005
    • Boulder, CO
    • Posts 836
    • Points 10,565

    Re: Installer background image casues stall

    RalphC:
    Can you try In finder, launch /System/Library/CoreServices/Installer.app. ...

    Ahhh. That's a good way to get around this. Thank you.

    It would be nice if it worked though...

     

    i7-5820(x99), 64GB, Win 8.1, GTX 1080ti [view my complete system specs]
  • Tue, Oct 22 2019 5:35 PM In reply to

    • curiosity
    • Top 150 Contributor
    • Joined on Thu, Oct 13 2005
    • Boulder, CO
    • Posts 836
    • Points 10,565

    Re: Installer background image casues stall

     

    Hmmm. The problem I have is how to mount the dmg without openeing the the Finder window. I tried:

    hdiutil attach -nobrowse <path to dmg>

    But I have the same problem, it gets stuck on a LOOOOOONG "Checksumming disk Image" process, and while this eventually works - it mounts the dmg in /Volumes/ but doesn't provide a GUI mountpoint. So I have to launch the installer from the command line:

    sudo installer -pkg <path to pkg> -target <path to target>

    All of which just to get it to install the application in less than 15 minutes of waiting per system....

    There has to be a better way.

    i7-5820(x99), 64GB, Win 8.1, GTX 1080ti [view my complete system specs]
Page 1 of 1 (5 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller