Latest post Fri, Sep 27 2019 2:31 PM by DStone. 17 replies.
Page 1 of 2 (18 items) 1 2 Next >
Sort Posts: Previous Next
  • Mon, Feb 4 2019 5:50 PM

    • RickP
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Cleveland, OH
    • Posts 74
    • Points 820

    DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    I have a number of 1080p/59.94 files recorded during one session on a Blackmagic Mini as DNxHD 90.  Some link as "DVxHD 90 (HD1080p)" and others as "Avid DNx Codec", both using the QuickTime plug-in.  The DNxHD 90 linked files play back smoothly while the Avid DNx identified files stutter. 

    Why are they not all seen as one or the other.  Can I change the designation of the link?

    I'm using a Windows 7 PC running MC2018.10.

    Media Composer v2018.10 on (30) 27" Core i7 Quad-core iMacs with 16GB RAM and 23 iMac Pros with 32GB RAM, plus an assortment of HP i5s running Windows... [view my complete system specs]
  • Mon, Feb 4 2019 6:14 PM In reply to

    • DonE
    • Not Ranked
    • Joined on Tue, Aug 18 2009
    • California, USA
    • Posts 139
    • Points 1,695

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    Does the console give you any clues when you first do the link or when you play them? AFAIK you can't change the designation. I wish you could.

    4x AMC/Sy 20.12- Win10 Pro 64 20H2- i9-9900K 32GB- Radeon RX580- QT779- BMD UltraStudio Monitor 3G DV11.6 ** 1x AMC/Sy 8.6.5-dongle- OSX 10.10.5-Mac... [view my complete system specs]
  • Mon, Feb 4 2019 7:52 PM In reply to

    • RickP
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Cleveland, OH
    • Posts 74
    • Points 820

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    When I play a clip tagged as Avid DNx Codec I usually get:

    [QuickTime Plug-In] The movie has variable sample duration.QuickTime: Unknown error

    plus multiple lines of just:

    QuickTime: Unknown error

    on the console.  I haven't seen it ever when playing clips tagged as DNxHD 90.  Very strange, as these clips were recorded one after the other in the space of 6 hours. 

    This was a casting call and the clips, each trimmed on a separate timelime, are exporting with no issues.

    Media Composer v2018.10 on (30) 27" Core i7 Quad-core iMacs with 16GB RAM and 23 iMac Pros with 32GB RAM, plus an assortment of HP i5s running Windows... [view my complete system specs]
  • Tue, Feb 5 2019 4:34 PM In reply to

    • DonE
    • Not Ranked
    • Joined on Tue, Aug 18 2009
    • California, USA
    • Posts 139
    • Points 1,695

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    Does playback stutter on all settings of the Video Quality Menu? I have had the same problem with ProRes when Avid Links the generic codec rather than the fully supported one.

    4x AMC/Sy 20.12- Win10 Pro 64 20H2- i9-9900K 32GB- Radeon RX580- QT779- BMD UltraStudio Monitor 3G DV11.6 ** 1x AMC/Sy 8.6.5-dongle- OSX 10.10.5-Mac... [view my complete system specs]
  • Tue, Feb 5 2019 5:03 PM In reply to

    • RickP
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Cleveland, OH
    • Posts 74
    • Points 820

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    Changing the Video Quality setting doesn't appear to change the playback issues.  Some clips  stutter while others, the video slows while the audio plays normally.  Pause/release resets the audio, but it pull ahead again. 

    One sometimes doesn't show any video, but it transcoded fine and was usable.

    Very strange.

    Media Composer v2018.10 on (30) 27" Core i7 Quad-core iMacs with 16GB RAM and 23 iMac Pros with 32GB RAM, plus an assortment of HP i5s running Windows... [view my complete system specs]
  • Tue, Feb 5 2019 5:30 PM In reply to

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    Try linking then exporting it out as Same As Source (use Avid codec).

     

    Relink. Curious if that fixes it.

     

    MC 2021.6, W10, MSI X299M, Intel 9940X, Gigabyte 2080Ti Waterforce, 64GB RAM, Samsung 970 EVO M.2 SSD, BM Mini monitor & Dell UP2718Q. MBP 2019, OSX... [view my complete system specs]
  • Tue, Feb 5 2019 6:32 PM In reply to

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    Use Mediainfo to examine the files and see what the difference is. There must be a difference for Avid to treat them differently.

    HP Z840 3.1GHZ 20cores 128GB RAM M4000 GPU 1TB NVMe drive HP Z book 17 G2 2.7GHZ Quad core 32GB RAM Nvidia K3100M 1TB SSD drive ACI Moderator. I'm... [view my complete system specs]

     

    Broadcast & Post Production Consultant / Trainer  Avid Certified Instructor VET

     

    QC/QAR Training - Understanding Digital Media - Advanced Files * Compression - Avid Ingest - PSE fixing courses and more

    All bespoke and delivered onsite at yours. Or delivered via hosted Zoom session.

     

    T 07581 201248 | E pat@vet-training.co.uk | www.vet-training.co.uk|

     

  • Tue, Feb 5 2019 7:32 PM In reply to

    • RickP
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Cleveland, OH
    • Posts 74
    • Points 820

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    First thing I tried before posting.  MediaInfo shows them as identical.  That's what has me flummoxed.

    Media Composer v2018.10 on (30) 27" Core i7 Quad-core iMacs with 16GB RAM and 23 iMac Pros with 32GB RAM, plus an assortment of HP i5s running Windows... [view my complete system specs]
  • Wed, Feb 6 2019 4:23 PM In reply to

    • DonE
    • Not Ranked
    • Joined on Tue, Aug 18 2009
    • California, USA
    • Posts 139
    • Points 1,695

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    MediaInfo is a very helpful tool but it only goes so deep into QuickTime. It looks like Avid is finding a diffence in the BMD files.

    It looks to me like Avid has made many changes to QuickTime Linking as new versions are released. Back around MC8.8x they started working to remove dependencies on QuickTime libraries. I don't have experience with the BMD files but work with large numbers of ProRes files made by different vendors. If Avid finds something it is unsure of it assign a generic codec and playback will stutter just as these BMD files are doing. I have a ProRes encoder we use daily that use to Link fine in MC8.6.5 but has not worked correctly since before 2018.x. In our shared environment I can first Link the files in 8.6.5 and then open the project in 2018.12 and they play fine at full quallity Green10. If I re-Link in 2018.12 the codec goes back to generic and playback will stutter like crazy. Go figure... It would be great if when Avid panics due to something in a file it doesn't understand it would let me select a codec and see if it works. With RickP's BMD files and my ProRes files, they Transcode fine.

    4x AMC/Sy 20.12- Win10 Pro 64 20H2- i9-9900K 32GB- Radeon RX580- QT779- BMD UltraStudio Monitor 3G DV11.6 ** 1x AMC/Sy 8.6.5-dongle- OSX 10.10.5-Mac... [view my complete system specs]
  • Wed, Feb 6 2019 4:39 PM In reply to

    • DonE
    • Not Ranked
    • Joined on Tue, Aug 18 2009
    • California, USA
    • Posts 139
    • Points 1,695

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    Dom Q. Silverio:

    Try linking then exporting it out as Same As Source (use Avid codec).

     

    Relink. Curious if that fixes it.

     

    This is an interesting idea. I don't have the BMD files but I tried it with ProRes (on MAC). If Avid has assigned the generic codec (Link in 2018.12) it will not export SAS, saying there are no clips to export that way. If the supported codec is assigned (Linked in 8.6.5 first) it will export SAS just fine from 2018.12. The SAS export then Links in 2018.12 correctly!

    Thanks Dom!

    4x AMC/Sy 20.12- Win10 Pro 64 20H2- i9-9900K 32GB- Radeon RX580- QT779- BMD UltraStudio Monitor 3G DV11.6 ** 1x AMC/Sy 8.6.5-dongle- OSX 10.10.5-Mac... [view my complete system specs]
  • Wed, Feb 6 2019 7:09 PM In reply to

    • RickP
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Cleveland, OH
    • Posts 74
    • Points 820

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    Finally got the time to try an export "Same As Source".  Pretty much the same as DonE's results - the "Avid DNx Codec" ID'd files will not export claiming the resolutions were not supported. 

    The Media Composer's Get Info window on one of these files shows "unknown" Chroma Subsampling rather than the 4:2:2 of those recognized as DNxHD90.

    Media Composer v2018.10 on (30) 27" Core i7 Quad-core iMacs with 16GB RAM and 23 iMac Pros with 32GB RAM, plus an assortment of HP i5s running Windows... [view my complete system specs]
  • Wed, Apr 24 2019 12:12 PM In reply to

    • danny
    • Not Ranked
    • Joined on Sun, Jan 24 2010
    • Posts 101
    • Points 1,165

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    Pat - whilst not strictly a DNX issue, I wonder if my experience might shed some light...

    I recently posted an issue "ProRes not able to consolidate" - due to "foreign compression type". Other symptoms include: no timecode displaying on audio tracks, odd fps, displays as "ProRes" (as opposed to "Apple ProRes"). This has huge implications for sequence consolidating for delivery to grading and audio mix houses.

    My workaround is to cut the clip into and Avid timeline (with the same timecode as the clip) and export SAS, direct audio. The exported clip links fine, with timecoded audio, displays as "Apple ProRes HQ HD 1080i".

    What is weird is that by using the MediaInfo tool, the original (dodgy, according to my Avid) clips are described as:

    Format: Quicktime, Format/Info: Original Apple Specification.

    Whereas the clips that I export SAS (and can then re-link and consolidate ino problem) are described as:

    Format: MPEG-4, Format Profile: Quicktime.

     

    I have checked with my copy of MC 2018 different partition, same OS) and get the same issues. I have edited ProRes HQ rushes and other ProRes HQ xfers for years with no issues and (since Avid v.7) been able to link, consolidate and export with no problems.

    Given that the original files were created on a mac in a post house using FCP7 and I'm editing on a mac OS 10.12.6, with Avid 8.9.1 (no Windows or third party "fake PRoRes" involved, I wonder if Avid's Quicktime AMA plugin might have altered in recent versions?

    Mac 3Ghz 8-core cylinder Xeon E5. 32GB 1866Mhz DDR3. AMD D700 graphics x2. OS 10.12.6 with MC/Symphony 8.9.1 and 10.14.6 with MC2020 [view my complete system specs]
  • Wed, Apr 24 2019 12:25 PM In reply to

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    Oh we know the Avid QuickTime AMA plugin is undergoing signidicant changes as they gear up to not being reliant on the old legacy QT engine.

    And that will have unexpected implications. Best to raise it as a support issue and ensure engineering know the issue exists.

     

    HP Z840 3.1GHZ 20cores 128GB RAM M4000 GPU 1TB NVMe drive HP Z book 17 G2 2.7GHZ Quad core 32GB RAM Nvidia K3100M 1TB SSD drive ACI Moderator. I'm... [view my complete system specs]

     

    Broadcast & Post Production Consultant / Trainer  Avid Certified Instructor VET

     

    QC/QAR Training - Understanding Digital Media - Advanced Files * Compression - Avid Ingest - PSE fixing courses and more

    All bespoke and delivered onsite at yours. Or delivered via hosted Zoom session.

     

    T 07581 201248 | E pat@vet-training.co.uk | www.vet-training.co.uk|

     

  • Mon, Sep 23 2019 8:38 PM In reply to

    • RickP
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Cleveland, OH
    • Posts 74
    • Points 820

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    Well, this sort of fell off my radar after the project was completed.  But, the same senerio came up last week, with the same issues.  And, worse.  My first pass was just like the original project - correctly ID'd clips play back fine, "Avid DNx Codec" stutter and lag.  Tweaking some of my timelines a day later, and the clips do not play.  Then, the PC freezes and reboots.  Repeatedly.

    I also tried setting the Mini to record DNxHD 145 (DNxHD 290 for 59.94).  Same problem.

    I will try the Blackmagic forums to see if there is any mention of this.

    Media Composer v2018.10 on (30) 27" Core i7 Quad-core iMacs with 16GB RAM and 23 iMac Pros with 32GB RAM, plus an assortment of HP i5s running Windows... [view my complete system specs]
  • Mon, Sep 23 2019 9:13 PM In reply to

    Re: DNxHD 90 files linked as Avid DNx Codec rather than DNxHD 90

    I would try opening the files in Resolve and see if there is any discernable difference in how Resolve sees them vs MC. Also you could try the program GSpot to investigate the files.

    Good luck!

    "When I spent 60k on a discreet edit digisuite system 10 years ago someone came up to me to offer fcp 2, I said it was a scam too." -Ric

Page 1 of 2 (18 items) 1 2 Next >

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller