Latest post Fri, Dec 6 2019 7:58 AM by Robert Martindale. 12 replies.
Page 1 of 1 (13 items)
Sort Posts: Previous Next
  • Thu, Oct 25 2018 6:31 AM

    Installation error - missing files

    Greetings all

    Since 2018.9 I've been getting odd missing file errors when installing new versions of Media Composer. I never had this with previous installs. I've tried different applications to unzip the installer file downloaded from Avid, but I get the same error.

    Here's the odd thing - if I just ignore the error messages and continue with the installation, Media Composer works fine! Even the audio effects mentioned in the error messages work. It seems to looking for missing .png file initially and then the entire fx file upon configuration the first time I launch MC. 

    Any ideas?


    Avid Media Composer 2020.4 HP ZBook 17 Gen3, i7-6700HQ CPU @ 2.60Ghz Win 10, 64GB RAM [view my complete system specs]
  • Thu, Oct 25 2018 8:03 AM In reply to

    Re: Installation error - missing files

    The file path depth for installation is too long.  I take it the installer is on a network drive? Move the Install folder to your local drive you are installing on.  I did ask this to be resolved a few years back but nothing yet.

    MC/SN 2018.6+7+8+9+12 x 16 Z400/420/440/800/820 PC's on W7/10 x64. 3 x Mac, 4 x PT 2019.12 HDX, S6 , X-MON, all on PCs. NEXIS E4 & ISIS 5000 X... [view my complete system specs]
  • Thu, Oct 25 2018 8:25 AM In reply to

    Re: Installation error - missing files

    Thanks for your reply!

    The installation actually ran from my laptop's local drive, but your assessment of the file name length makes perfect sense.

    I've been running 2018.10 since last night and so far no issues, even with all the error messages I got during installation. So unless my system starts breaking down I'll just live with it for the time being.

    So Avid, I'm adding my voice to ShadenFreude's - please look into this? Thanks

    Avid Media Composer 2020.4 HP ZBook 17 Gen3, i7-6700HQ CPU @ 2.60Ghz Win 10, 64GB RAM [view my complete system specs]
  • Thu, Oct 25 2018 12:21 PM In reply to

    • BarkinMadd
    • Top 25 Contributor
    • Joined on Fri, Nov 4 2005
    • Ontario, Canada
    • Posts 4,777
    • Points 62,185

    Re: Installation error - missing files

    Avid's position for years is to run the installer from a top level folder. I would suggest uninstalling MC and repeating the install from a short folder path. Otherwise if you have any issues in the future you may wonder if the faulty installation is to blame. 

    MC 2020.8 | QT 7.7.9 | Continuum 2020.5 | Sapphire 2020.5 | Mocha Pro 2020.5 | Titler Pro 7.3 | Windows 10 Pro x64 (2004) | System: Asus x299, i9-7940X... [view my complete system specs]

    Steve

    ______________________

    www.nelliedogstudios.com

  • Thu, Oct 25 2018 1:31 PM In reply to

    • Marianna
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Avid
    • Posts 11,380
    • Points 233,240
    • Avid Beta Moderators
      Avid Customer Advocate
      Avid Developer Moderator
      BlogAuthor
      SystemAdministrator

    Re: Installation error - missing files

    Also to add to BarkinMadd's suggestions........

    This can occur to if the downloaded installer .zip file didnt extract all the files contained in it properly. The installer .zip file should not be placed in a folder that causes the name to exceed the Windows limit of 260 characters.

    Click Ignore through all the errors and allow the installaiton to complete
    Move the installer .zip file to the root level of your C drive and extract it there
    Run the installer and choose to perform a repair install

    Marianna

    Director of CSM | Customer Advocate [view my complete system specs]
  • Thu, Oct 25 2018 6:17 PM In reply to

    • Marianna
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Avid
    • Posts 11,380
    • Points 233,240
    • Avid Beta Moderators
      Avid Customer Advocate
      Avid Developer Moderator
      BlogAuthor
      SystemAdministrator

    Re: Installation error - missing files

    Corne Scheepers:

    Thanks for your reply!

    The installation actually ran from my laptop's local drive, but your assessment of the file name length makes perfect sense.

    I've been running 2018.10 since last night and so far no issues, even with all the error messages I got during installation. So unless my system starts breaking down I'll just live with it for the time being.

    So Avid, I'm adding my voice to ShadenFreude's - please look into this? Thanks

    Windows has a 260 character length limit Corne - its not Avid its Microsoft

    Marianna

    Director of CSM | Customer Advocate [view my complete system specs]
  • Thu, Oct 25 2018 6:46 PM In reply to

    Re: Installation error - missing files

    Okay, I won't argue with that. But still wonder if I'm running a fully installed 2018.10 or if I'm missing a few pieces. I'm guessing I'm fine because I edited the whole day without any issues. If the doors and the steering wheel weren't bolted on properly I suppose Media Composer wouldn't have allowed me to take this car out of the garage this morning when I launched application..?

    I'll run the installer from a drive root sometime and see if that makes a difference

    Avid Media Composer 2020.4 HP ZBook 17 Gen3, i7-6700HQ CPU @ 2.60Ghz Win 10, 64GB RAM [view my complete system specs]
  • Thu, Oct 25 2018 6:48 PM In reply to

    Re: Installation error - missing files

    BarkinMadd:

    Avid's position for years is to run the installer from a top level folder. I would suggest uninstalling MC and repeating the install from a short folder path. Otherwise if you have any issues in the future you may wonder if the faulty installation is to blame. 

    Thanks I'll try that

    Avid Media Composer 2020.4 HP ZBook 17 Gen3, i7-6700HQ CPU @ 2.60Ghz Win 10, 64GB RAM [view my complete system specs]
  • Mon, Oct 29 2018 8:14 AM In reply to

    Re: Installation error - missing files

    Just a note that this issue has been resolved. I ran the installer from C: as advised and did not receive any errors again.

    Thanks for the advice everyone!

    Happy editing

    Avid Media Composer 2020.4 HP ZBook 17 Gen3, i7-6700HQ CPU @ 2.60Ghz Win 10, 64GB RAM [view my complete system specs]
  • Mon, Oct 29 2018 8:56 AM In reply to

    Re: Installation error - missing files

    Glad you solved it, and thanks for posting the solution.

    Media Composer 2020.9 w/Symphony/SS/PF options, HP Z-Book G6 17", i7-9850H 2.60GHz, 32gb RAM, NVIDIA Quadro RTX 3000, Windows 10 Pro [view my complete system specs]

    "There is hardly anything in the world that some man cannot make a little worse and sell a little cheaper, and the people who only consider the price are this man's lawful prey."  - John Ruskin (1819-1900)

     

    Carl Amoscato | Freelance Film & Video Editor | London, UK

  • Mon, Nov 25 2019 4:34 PM In reply to

    • mecom
    • Not Ranked
    • Joined on Thu, Feb 22 2018
    • Posts 6
    • Points 70

    Re: Installation error - missing files

    I understand the Windows OS limit and agree that there is an easy workaround.

    However, if I do not install manually, but from the donwload/install-button inside Avid Link, I wished this limit had been taken into consideration. Because then it is Avid Link that puts the temporary installation files in a place where it exceeds the character limit. I would like to suggest that as an imprivement for future updates.

    Or did I miss a setting inside Avid Link, where I can define where it puts installation files?

    In the meantime, the manual installation from a top level folder works fine :)

  • Mon, Dec 2 2019 6:04 AM In reply to

    • rolinhard316
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Southern California
    • Posts 23
    • Points 325

    Re: Installation error - missing files

    I had the same issue with Avid Link. The only solution was manual install from the root of the system drive. I didn't have this issue with the last point update.

    MC 8.8, HP Z800, Dual Quad 3.2GHz, 24Gb RAM, Win10 Pro 64bit, NVIDIA K4000, Blackmagic DeckLink 4K Extreme, RED Rocket-X, CalDigit HDPRO [view my complete system specs]
  • Fri, Dec 6 2019 7:58 AM In reply to

    Re: Installation error - missing files

    7 Zip is my go to extractor for difficult avid zipped files...its free and does not give the error messages referenced when used

    i always extract at a root of a drive

    it just works.

    that is what got a clean 2019.11 install here, after error messages using avid link.  instead, a file from the download center was unzipped using 7zip and installed.

Page 1 of 1 (13 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller