Latest post Fri, Dec 16 2011 10:11 PM by Ken Lent. 0 replies.
Page 1 of 1 (1 items)
Sort Posts: Previous Next
  • Fri, Dec 16 2011 10:11 PM

    • Ken Lent
    • Not Ranked
    • Joined on Tue, Dec 18 2007
    • California
    • Posts 129
    • Points 1,375

    Bug report: Crash on generating a subclip near start of HDV capture

    I encountered a bug in MC 5.5.3 while capturing from an HDV tape, from 00;08;00 to 46;36;00.  (I generally capture whole tapes for multicam productions.)  The capture seemed to proceed without a hitch until it got to the very end, at which point MC crashed with this report:

         An error has occurred:
         Assertion failed: position >= 0
         File: ..\..\..\MediaComposer\Digitize\ASubclipQueue.c, Line: 566

    I closed MC, restarted my PC, and tried again, hoping it was just caused by a wayward gamma ray, but I also changed the end timecode to 46;34;00 in case there was a bad spot at the end.  I got the same result.

    Closed MC again, restarted my PC, and tried capturing only from 00;08;00 to 00;59;28, and still got the same result, this time at the end of the minute.

    I thought about the fact that there were some extremely brief throwaway scenes at the beginning of the tape.  I wondered if one of them started right at 00;08;00 and MC capture had counted one too many, and then ran past the end of an array when generating subclips at the end of the capture.  As an experiment, I tried capturing from 00;07;00 to 00:59:28, which worked fine and also revealed that one scene started at 00;07;27, just three frames BEFORE my original starting point.

    Then I successfully captured from 00;09;00 to 46;36;00.  (That beginning second was not critical, and I like to leave at least an 8-second gap, so I can be sure I can recapture at a later time.)

    So there appears to be a bug in MC 5.5.3 (and likely in other versions) that MC miscounts subclips if capture begins just before a scene change on a tape.  I will leave it to the Avid programmers to determine what the range is for that error--it will probably be clear from careful inspection of your code.

    And if anyone else encounters that problem in the meantime, the workaround is easy; just move your start point 1 second earlier or later, and try again!

    Core i7 930 PC 2.8GHz / 18GB RAM / Win10 Pro 64bit / nVidia Quadro K2200 (driver 411.95) / MC 2018.12.9 (Symphony/PF/SS) / BCC AVX 10.0.2 / NewBlue Titler... [view my complete system specs]
    Filed under: , , ,
Page 1 of 1 (1 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller