Media Composer | First Forum

This forum is for Media Composer | First released on June 29th 2017. This is the place to seek advice, help, mentoring from experienced editors. This forum is especially helpful if you are new to editing or just want to become part of the Avid community.
Write a New Post
Page 3 of 29 (576 items) < Previous 1 2 3 4 5 Next > ... Last »
Topics Replies Views
Popular Post
Application manager is always in offline-mode by Holger Jahn
» Latest post by danny , Wed, Feb 5 2020 3:04 PM
5 3,212
Popular Post
Media Composer First won't load by Ondavon
» Latest post by camoscato , Sat, Feb 1 2020 7:29 PM
4 927
Popular Post
Please help. Project completely disappeared by aviduser2018
» Latest post by camoscato , Sun, Jan 12 2020 5:22 AM
4 1,213
Popular Post
Unable to launch application. pls save me. by obscurity20200
» Latest post by camoscato , Sat, Jan 4 2020 9:55 PM
1 639
Popular Post
Dolby AC3 AVCHD for MC 2019.12 by Dennis
» Latest post by RalphC , Sat, Jan 4 2020 2:45 PM
1 759
Popular Post
Quicktime export just keeps starting over by audio2
» Latest post by loxley77 , Sat, Jan 4 2020 3:11 AM
11 2,099
Popular Post
Media Composer First 8.9.1 Exception Can't create a directory by Keith R
» Latest post by Dan , Thu, Jan 2 2020 11:48 PM
12 8,078
Popular Post
Media Composer | First 2019.12 is Live by Marianna
» Latest post by Marianna , Mon, Dec 23 2019 8:19 PM
0 969
Popular Post
Media Composer First not responding by Michael_Knight
» Latest post by DStone , Sun, Dec 22 2019 11:02 PM
7 1,340
Popular Post
initializing plugin: quicktime_opclient.avx hangs First 2019.11 by Ivo
» Latest post by GT , Wed, Dec 11 2019 12:03 PM
1 1,841
Popular Post
2019.11, unable to see media in Source Browser by Jon Hallett
» Latest post by Jon Hallett , Fri, Dec 6 2019 4:47 PM
1 634
Popular Post
Media Creation results in black clips by butterfly
» Latest post by butterfly , Fri, Dec 6 2019 7:04 AM
5 1,009
Popular Post
Effect Mode Bug by Rob
» Latest post by Rob , Tue, Nov 26 2019 2:16 PM
0 755
Popular Post
What colour space setting to use by Sean
» Latest post by Pat Horridge , Sun, Nov 24 2019 4:42 PM
1 568
Popular Post
Problem with Avid Link when trying to launch Avid MC First by Asticoco
» Latest post by Asticoco , Fri, Nov 22 2019 6:58 PM
14 1,755
Popular Post
Media Composer | First 2019.11 Available by Marianna
» Latest post by Marianna , Tue, Nov 19 2019 2:11 PM
0 1,116
Popular Post
Assertion Failed Error on Publishing to Local Drive by walkerrun
» Latest post by walkerrun , Tue, Nov 5 2019 11:35 PM
2 1,595
Popular Post
MCState by bgrieve@dreampool.com.au
» Latest post by Marianna , Tue, Nov 5 2019 3:32 PM
1 948
Popular Post
Avid First add and export markers? by adam5000
» Latest post by adam5000 , Wed, Oct 30 2019 4:59 PM
2 783
Popular Post
DV cam to MC soft by Henrik Fleischer
» Latest post by DStone , Wed, Oct 16 2019 4:50 PM
1 729
Write a New Post
Page 3 of 29 (576 items) < Previous 1 2 3 4 5 Next > ... Last »
More Options

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller