Browse Forum Posts by Tags

Showing related tags and posts for the Licensing Options forum. See all tags in the site
  • Winter promo did not work

    Hi! I was buying a annual subscription last week (16/2). You have a quick button "buy" to the right when you push the "Media composer" button in your web site. I pushed buy and noticed your "Winter promo get 10% off" at the next page. I also say enter code "winter"... (read more)
    Posted to Licensing Options (Forum) by kribba on Fri, Feb 23 2018
  • Ilok issue

    I have an Avid MC 8.3 subscription license, so no dongle. At first Avid MC worked fine but now every time I start up MC it says I have to run Ilok first. I had never even heard of Ilok since Avid MC 8.3 started up fine. I now have Ilok installed and have created an account and now every time I run Ilok... (read more)
    Posted to Licensing Options (Forum) by Camiel Ledderhof on Sun, Apr 19 2015
  • Re: Support/Upgrade plan ON HOLD | what does that mean?

    No pounce intended but after paying for upgrade and support all i got was two emails stating : Subscription | System ID Validation Request | We have received your Avid Webstore Support request - xxxxxxxx details of which are located at the bottom of this email. We will reply to your query as soon as... (read more)
    Posted to Licensing Options (Forum) by Peter Hjorth on Wed, Dec 31 2014
Page 1 of 1 (3 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller