Latest post Wed, Aug 29 2018 6:23 PM by xudon. 0 replies.
Page 1 of 1 (1 items)
Sort Posts: Previous Next
  • Wed, Aug 29 2018 6:23 PM

    • xudon
    • Not Ranked
    • Joined on Tue, Apr 15 2014
    • Posts 14
    • Points 180

    Error in deserializing body of reply message for operation 'GetChildren'

    Hi,

    I'm scanning folders and clips in folders. But sometimes I got errors to state the xml returned has special characters.

    This was the actual error (I think it was from the clips):

    System.Xml.XmlException: The token '"' was expected but found '' -- I can see something with notepad++ between very last two single quotes.

    My question is:

    Is there a way to check the returns in text (not xml) so I can find what special characters caused the problems?

    Or is there a way to set encoder for returned xml to strip out special characters so returned xml would be in valid format?

    Here is my code:

                Dim param As New GetChildrenType()

                param.IncludeFolders = True
                param.IncludeFiles = True
                param.InterplayURI = sProjectFolderName
                param.IncludeMOBs = True

                Try
                    Dim response As GetChildrenResponseType = port.GetChildren(creds, param)
                    If response.Results.Length > 0 Then
                        For Each ad As AssetDescriptionType In response.Results

                          'get info

                        Next
                    Else
                        lblProjectFolderDisplay.Text = "No results."
                    End If
                Catch ex As Exception
                    lblProjectFolderDisplay.Text = ex.Message.ToString
                End Try

     

    Thanks a lot for the help,

     

    Don

Page 1 of 1 (1 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller