Latest post Wed, Apr 18 2018 6:29 PM by Job ter Burg. 9 replies.
Page 1 of 1 (10 items)
Sort Posts: Previous Next
  • Mon, Apr 16 2018 9:24 PM

    • gstrudler
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Portland, OR
    • Posts 21
    • Points 275

    Audio Track Effects causing interface slowness/lagging

    I've been fighting lagging issues for a while and finally just figured out what was causing it for me: audio track effects. Bypassing the effects lead to no improvement. In my case, the Play Length toggle made no change in behavior. The only cure was to remove all track effects from every track (including the master).

    I recently did a full clean install (new hard drive, fresh OS install, etc) as part of my troubleshooting as I was having problems prior as well, so I'm pretty confident my current install is ok. Currently on MacOS 10.13.4 and MC 2018.4, but as mentioned I've been having issues for a little while now, I'm going to guess back to MC 8.6-ish.

    The lag is most predominant with anything sequence related, but also causes sluggishness with loading clips in the source monitor and sometimes application switching as well. Loading a sequence with no audio track effects makes the interface snappy again like it should be.

    Any thoughts as to why this might be? Audio track effects are a pretty big part of my workflow. I can get around it somewhat by making sure they are the last step of my edit now that I know they are the issue, but obviously it would be great if they worked correctly without killing the interface.

    MacOS 10.13.4, Media Composer 2018 w/ Symphony option, dual 3.46GHz 6-core 5.1 Mac Pro, 24GB RAM, Nvidia GTX 1080, Nitris DX, SSD system drive, 2-drive... [view my complete system specs]
  • Mon, Apr 16 2018 10:13 PM In reply to

    Re: Audio Track Effects causing interface slowness/lagging

    But that Mac Pro 5,1 from your user specs is an 8-year old computer. That would be my first worry.

    Media Composer /w Symphony option | PT-HD | Win7Pro64 HP | OSX MBP | ISIS5000 | Nitris DX | Artist Mix & Transport & Color | AJA T-Tap | Decklink... [view my complete system specs]
  • Mon, Apr 16 2018 10:34 PM In reply to

    • gstrudler
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Portland, OR
    • Posts 21
    • Points 275

    Re: Audio Track Effects causing interface slowness/lagging

    I'm pretty sure the 5,1 is actually still a qualified system.

    The same squence I was testing with had multiple tracks of video with effects including BCC chroma keys, mocha stabilization, timewarps, and more, all running without issue once the audio track effects were gone.

    It looks like it might be some issue with the way AAX plug-ins are being handled if I were to venture a guess.

    MacOS 10.13.4, Media Composer 2018 w/ Symphony option, dual 3.46GHz 6-core 5.1 Mac Pro, 24GB RAM, Nvidia GTX 1080, Nitris DX, SSD system drive, 2-drive... [view my complete system specs]
  • Mon, Apr 16 2018 10:58 PM In reply to

    Re: Audio Track Effects causing interface slowness/lagging

    But those video effects are clip-based and rendered. Track effects need to be done in realtime.

    Media Composer /w Symphony option | PT-HD | Win7Pro64 HP | OSX MBP | ISIS5000 | Nitris DX | Artist Mix & Transport & Color | AJA T-Tap | Decklink... [view my complete system specs]
  • Mon, Apr 16 2018 11:43 PM In reply to

    • gstrudler
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Portland, OR
    • Posts 21
    • Points 275

    Re: Audio Track Effects causing interface slowness/lagging

    Once the sequence starts playing, it plays fine, so I'm pretty sure it's not a realtime-capable issue. Watching my CPU monitor it hovers around 20% on playback with an occiasonal spike towards 28%, so it's not even close to being taxed. I know the hardware is old and there are other limitations in bandwidth and throughput besides just CPU cores & clockspeed, but I really don't think that's the issue here.

    Having the effects in place just creates a weird lag on most actions like entering and exiting trim mode, moving clips around on the timeline, loading clips in the source monitor, etc. Loading clips from a bin into the source monitor should have absolutely nothing to do with sequence track effects, and yet it makes a difference.

    Just for reference (espeically since I see you know PT), that sequence has three effects on A1 (Sonnox EQ & Dynamics, and RX6 de-noise) and two effects on the master (Sonnox Limiter and TC LM2n). However, even with only the LM2n (which shouldn't be very taxing at all) I still have a bad interface lag. Once every plugin is gone it clears right up. It feels like some coding issue where it's going for an AAX resource and bogs the whole thing down. 

    MacOS 10.13.4, Media Composer 2018 w/ Symphony option, dual 3.46GHz 6-core 5.1 Mac Pro, 24GB RAM, Nvidia GTX 1080, Nitris DX, SSD system drive, 2-drive... [view my complete system specs]
  • Tue, Apr 17 2018 5:22 PM In reply to

    Re: Audio Track Effects causing interface slowness/lagging

    Thanks for the detailed reply.

    Do you have Caps Locks on (audio scrub)? Does it make a difference if you turn that on or off? I'm informed that having Caps Lock on keeps the player running in the background.

    Media Composer /w Symphony option | PT-HD | Win7Pro64 HP | OSX MBP | ISIS5000 | Nitris DX | Artist Mix & Transport & Color | AJA T-Tap | Decklink... [view my complete system specs]
  • Wed, Apr 18 2018 12:43 PM In reply to

    • Marty
    • Top 150 Contributor
    • Joined on Sat, Dec 3 2005
    • Berlin, Germany
    • Posts 905
    • Points 10,530

    Re: Audio Track Effects causing interface slowness/lagging

    Yes, audio track effects can have a big impact on the performance of Media Composer. It also depends on the computer and plugins.

    The RX6 as a standard filter alone sounds quite heavy for the CPU because it always has to analyze your audio signal in realtime. I only use that as an audiosuite effect that you can render for difficult clips with lots of noise.

    When I'm using several Waves plugins on my older laptop, it takes forever to open a sequence.

    On my last project I had to use Avid's own filters because I had to share my sequences with an editor who didn't have the plugins. I was using a fast iMac with Dyn3 EQ, Channel Strip Compressor, Dyn3 DeEsser on dialogue tracks and Maxim on master track and it was pretty fast.

    all different setups in various editing suites. my own: MC 2018.2, OSX 10.12.6, iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 40GB RAM, Radeon... [view my complete system specs]

    www.film-editing.de

  • Wed, Apr 18 2018 1:40 PM In reply to

    • Tom Pearson
    • Top 50 Contributor
    • Joined on Thu, Mar 1 2007
    • Los Angeles CA / Minneapolis MN
    • Posts 2,106
    • Points 22,650

    Re: Audio Track Effects causing interface slowness/lagging

    Hi quick question are any of your Plugin's third party? and Two have you thought about upping the ram? im using 64 gig in my pro and fx work great

    Mac Pro 3.5 gig 6 core 64 gig ram D700 radons with ssd os drive with a 20 tb raid, Artist Mix and Artist color Artist control [view my complete system specs]

    Tom Pearson

    Director/Writer Big Picture Films

    Sound Designer/Sound Editor Hollywood Sounds

    WWLD

  • Wed, Apr 18 2018 6:10 PM In reply to

    • gstrudler
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Portland, OR
    • Posts 21
    • Points 275

    Re: Audio Track Effects causing interface slowness/lagging

    Tom Pearson:

    Hi quick question are any of your Plugin's third party? 

    Turns out this is the issue. I just did some brief testing and when using the Avid supplied plugins the system is fine, but it starts to bog down with third party plugins, with the Sonnox ones seeming to be the worst offenders. I've thought about getting more RAM, but my memory pressure isn't showing any issues so that doesn't appear to be a problem (but I know having more on tap never hurts).

    Looks like I might have to start thinking about getting a Pro Tools license...

    MacOS 10.13.4, Media Composer 2018 w/ Symphony option, dual 3.46GHz 6-core 5.1 Mac Pro, 24GB RAM, Nvidia GTX 1080, Nitris DX, SSD system drive, 2-drive... [view my complete system specs]
  • Wed, Apr 18 2018 6:29 PM In reply to

    Re: Audio Track Effects causing interface slowness/lagging

    I think both the Sonnox EQ and the RX require quite a bit of latency compensation, so that may come into play.

    Media Composer /w Symphony option | PT-HD | Win7Pro64 HP | OSX MBP | ISIS5000 | Nitris DX | Artist Mix & Transport & Color | AJA T-Tap | Decklink... [view my complete system specs]
Page 1 of 1 (10 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller