Latest post Sun, Mar 11 2018 7:40 AM by jayRav. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • Sat, Mar 10 2018 9:44 PM

    • jayRav
    • Not Ranked
    • Joined on Sat, Mar 10 2018
    • Posts 2
    • Points 20

    AVID account login issues

    Hi,

    I am having issues with AVID login since in the afternoon today.

    Error message :

    "There has been an error.
    Sorry for the inconvenience, but something has gone wrong and we are working quickly to fix it.
    Please try back later."


    Can someone verify and let me know if this will be fixed soon. I urgently need to use the tool.

    Thank you.

  • Sun, Mar 11 2018 5:54 AM In reply to

    Re: AVID account login issues

    What version of what Avid product are you trying to use?

    Media Composer 2018.11 w/Symphony/SS/PF options, HP Envy 17t-j100 Quad Edition laptop, Windows 10 Pro, Intel Core i7 2.4GHz, 16 GB RAM, nVidia GeForce... [view my complete system specs]

    "There is hardly anything in the world that some man cannot make a little worse and sell a little cheaper, and the people who only consider the price are this man's lawful prey."  - John Ruskin (1819-1900)

     

    Carl Amoscato | Freelance Film & Video Editor | London, UK

  • Sun, Mar 11 2018 7:40 AM In reply to

    • jayRav
    • Not Ranked
    • Joined on Sat, Mar 10 2018
    • Posts 2
    • Points 20

    Re: AVID account login issues

    I think it wasn't the version related.

    my.avid.com website wasn't functional hence avid application manager couldn't authenticate me. 

    It wasn't working until this morning but started to work just now.

    Thank you for your response.

     

Page 1 of 1 (3 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller