Latest post Thu, Feb 13 2014 10:35 PM by aVienna. 0 replies.
Page 1 of 1 (1 items)
Sort Posts: Previous Next
  • Thu, Feb 13 2014 10:35 PM

    • aVienna
    • Not Ranked
    • Joined on Fri, Jul 21 2006
    • Vienna
    • Posts 52
    • Points 575

    AVX2 SDK performance issue impacting plug-ins

    I was seeking a grading solution without doing round trips and tried FilmLight Baselight Edition for Avid on Mac OS. I quickly got dissatisfied when I noticed that the fps drops to 6-7 fps when I feed a client monitor. As long as the Baselight Edition plug-in renders to its plug-in window the framerate stays high.

    In my case i was wondering if the AJA T-TAP perhaps is causing this. But FilmLight tech support explained that this is a performance issue of the AVX2 SDK that Avid needs to fix. The AVX2 API limits how quick the frames can be pushed out to the graphics adapter. Working around the limitation by writing directly to the hardware (in my case AJA T-TAP) also requires Avid to allow access to the graphics adapter. So again Avid needs to modify the source code.

    Perhaps Avid can give us an insight if this AVX2 SDK performance issue is high on the To-Do list at Avid?

    It certainly impacts all producers of plug-ins who use the AVX2 SDK. As the end user I can only appeal to Avid to fix this, all the expensive soft and hardware for grading and output is limited apparently.

    (Sorry for crossposting, there has been zero replies in the 'Complete your suite', I found this subforum and believe this is more likely to get an answer.)

    Avid MC 8.9, HP Z420: Intel Xeon E5-1650 v2, 6 cores @3.50GHz, 40GB RAM, Windows 10 Pro, Z TurboDrive 256GB as system disc, Thunderbolt 2 PCIe card, HP... [view my complete system specs]
Page 1 of 1 (1 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller