Latest post Sun, Jul 5 2009 3:25 PM by MichaelP. 10 replies.
Page 1 of 1 (11 items)
Sort Posts: Previous Next
  • Mon, May 4 2009 2:43 PM

    MetaFuze v1.2 Not Transcoding across all CPU cores

    Hello All


    I am writing to ask if anyone is having trouble with MetaFuze v1.2 and its slow transcoding...

    If you look at www.avid.com/red, you can see the various workflows for generating Avid Codec media and ALEs, from RED R3D files, for import in the offline stage of editorial using Media Composer.

    If you go down the Mac route of using Red Rushes, which you get from Red Alert, you can generate MOVs in the DNxHD codec of your choice plus an ALE. You can set the number of threads being processed to 8, and the transcoding will happen across all 8 cores in my Mac Pro. You can view this in Activity Monitor CPU usage. It is a lightning-fast transcode.

    If you go down the PC route (in this case I am using my Mac Pro in Boot Camp Win XP x32 mode) and use MetaFuze v1.2, which is the current version of the software as of May 2009, you can generate MXFs in the DNxHD codec of your choice plus an ALE. The question is why, when you set the number of threads to 8 (by going into Options > Transcode Configuration and setting the number of Local Threads to 8) does the transcoding happen only across 2 cores? You can view this in Task Manager. It is painfully slow.

    Any help most sincerely welcome. Thank you for your time.

    Mac Pro (Early 2008) 2.8GHz Dual Quad Core, 4GB RAM [view my complete system specs]
  • Mon, May 4 2009 3:13 PM In reply to

    Re: MetaFuze v1.2 Not Transcoding across all CPU cores

    FWIU, this is fixed in version 1.3 which should be released soon.

    "When I spent 60k on a discreet edit digisuite system 10 years ago someone came up to me to offer fcp 2, I said it was a scam too." -Ric

  • Wed, May 6 2009 1:13 PM In reply to

    • MichaelP
    • Top 50 Contributor
    • Joined on Thu, Oct 13 2005
    • Boston
    • Posts 2,444
    • Points 30,415
    • Avid Certified Instructors - Video
      Avid Employee
      Moderator: Film
      Moderator: MetaFuze

    Re: MetaFuze v1.2 Not Transcoding across all CPU cores

    Correct. We had to get creative to get around some of the implementatins in the SDK for multicore processing. Even RED's tools have issue as seen here:

    http://www.reduser.net/forum/showthread.php?t=29528

    v1.3 has been optimized to use all cores.

     

    Michael

    24p.com

  • Mon, May 25 2009 4:04 AM In reply to

    • lovis
    • Not Ranked
    • Joined on Mon, May 25 2009
    • Posts 4
    • Points 50

    Re: MetaFuze v1.2 Not Transcoding across all CPU cores

    Hello there, and thank you for your help,

    I'm using metafuze on my PC 8core whith the good spec for the machine and RED ONE camera rushes, and with an official avid version.

    I just wonder WHEN this Metafuze 1.3 or Metafuze 2

    will show up and be released.

    I noticed several huge problems using it,

    concerning for example the mass operations, it's ridiculously a lost of time with the actual version of metafuze

    Please implement the program with a few code lines, so I won't have to set HUNDREDS OF TIMES

    the resolution output I need, and the project name, and the debayer mode and so on.

    An 8 year old child would have thought about that. Could you also give us the possibility NOT TO LOAD the pictures of the preview while selecting several rushes ? Because I lose a precious time also.

    Plus, I often find my metafuze stucked without a reason, and it happens especially when I plan to go out to do something else while transcoding. PLEASE DO SOMETHING, because it's a real shame FOR MONTHS. I'm even wondering if the apple and quicktime consortium are doing a conspiracy in order to kill the RED ONE workflow. So this should maybe end up in a court ? I'd do that if I had a lot of money.

    I noticed that I had to switch from an application to an other (avid mojo MC 3.5, and metafuze 2.0)

    in order to avoid this metafuze stucking problem.

    Oh, and another thing is that there is always a problem on relinking the last transcoded rush.

    I found a technique, is that I have to throw to the trash the last created MXF, go back in Avid, Refresh media database, and restore the trash, and go back to avid, and try to relink. If it doesnt' work, sometime, I find using The avid Media tool that the rush was already detected. It's a pity.

    Thanks a lot for reading this, and please be professionnal and show up this 1.3 or 2 or whatever the next version will be called. Sorry I'm sooooo pissed of, but Avid deserve it.

     

    Louis Welti (editor)

  • Mon, May 25 2009 4:07 AM In reply to

    • lovis
    • Not Ranked
    • Joined on Mon, May 25 2009
    • Posts 4
    • Points 50

    Re: MetaFuze v1.2 Not Transcoding across all CPU cores

    Hello there, and thank you for your help,

    I'm using metafuze on my PC 8core whith the good spec for the machine and RED ONE camera rushes, and with an official avid version.

    I just wonder WHEN this Metafuze 1.3 or Metafuze 2

    will show up and be released.

    I noticed several huge problems using it,

    concerning for example the mass operations, it's ridiculously a lost of time with the actual version of metafuze

    Please implement the program with a few code lines, so I won't have to set HUNDREDS OF TIMES

    the resolution output I need, and the project name, and the debayer mode and so on.

    An 8 year old child would have thought about that. Could you also give us the possibility NOT TO LOAD the pictures of the preview while selecting several rushes ? Because I lose a precious time also.

    Plus, I often find my metafuze stucked without a reason, and it happens especially when I plan to go out to do something else while transcoding. PLEASE DO SOMETHING, because it's a real shame FOR MONTHS. I'm even wondering if the apple and quicktime consortium are doing a conspiracy in order to kill the RED ONE workflow. So this should maybe end up in a court ? I'd do that if I had a lot of money.

    I noticed that I had to switch from an application to an other (avid mojo MC 3.5, and metafuze 2.0)

    in order to avoid this metafuze stucking problem.

    Oh, and another thing is that there is always a problem on relinking the last transcoded rush.

    I found a technique, is that I have to throw to the trash the last created MXF, go back in Avid, Refresh media database, and restore the trash, and go back to avid, and try to relink. If it doesnt' work, sometime, I find using The avid Media tool that the rush was already detected. It's a pity.

    Thanks a lot for reading this, and please be professionnal and show up this 1.3 or 2 or whatever the next version will be called. Sorry I'm sooooo pissed of, but Avid deserve it.

     

    Louis Welti (editor)

  • Mon, May 25 2009 4:22 AM In reply to

    Re: MetaFuze v1.2 Not Transcoding across all CPU cores

    Interesting.  You end your post with, "... and please be professionnal ..."

    ... yet earlier you say, "... An 8 year old child would have thought about that ..." and then later, "... Avid deserve it ..."

    I'm just sayin'.

    Symphony 8.8.x w/Avid Nitris DX, HP z420, Windows 10, QT v7.7.x, Hexa Core 3.2GHz, 16GB RAM, nVidia Quadro Series 2000 w/353.82. 2TB Boot, 2 x 3TB internal... [view my complete system specs]

    "There are few technological barriers.  You can fix almost anything if you throw enough money at it."
    *******************************
    Randall L. Rike, ACI, ACSR Mac*Win*Unity*ISIS*DS
    Systems Engineer @ BET Networks [a Viacom company]
    (wwld)

  • Mon, May 25 2009 1:42 PM In reply to

    • lovis
    • Not Ranked
    • Joined on Mon, May 25 2009
    • Posts 4
    • Points 50

    Re: MetaFuze v1.2 Not Transcoding across all CPU cores

    Hello Randall,

    you're right, i'm not very polite,

    but there is nothing personnal agains you guys on the forum.

    This post is moreless destined to the head chief of the program developpers.

    You can be sure that its really a bad thing for Avid with or without my yelling post.

    Saying "avid deserves it" and being wrong, would imply that nobody has already sent anything about those serious issues about metafuze, which is not an option ! I'm just saying. Oh, and believe me I have other things to do than talk about all thoses!

    Now, some hour later, please accept apologies for my approx english and my hot blood.

     

    The thing is, that I check on the whole whole internet for solutions of avid metafuze's 1.2 problem,

    and I never found anything, not even a clue, and I think that this soft version is soooo imperfect, that i really don't understand why no one from avid reacted (on red users forum for exemple) would see what was wrong.

    Nowadays organisations are so complex, that as a client, you cannot hit anyone, and you never know who to tell in order to have a feedback from the competent/concerned persons.

    I would add that maybe if the autosave of avid Media composer is shutted down, the synchronisation of the 2 fellowing things:

    -avid mdb refresh through autosave or CTRL(+ALT)+S

    -metafuze ending transcoding a rush

    will empeach metafuze to go down.

     

    Of course if you had a link for the beta version of the Metafuze 1.3 that would be really great !

     

    You have a nice day.

     

    Bye

    Louis

     

    PS: check here there is a good sentence or two for avid marketing line:

    http://www.reduser.net/forum/showthread.php?t=27664&page=2

     

  • Mon, May 25 2009 3:36 PM In reply to

    • MichaelP
    • Top 50 Contributor
    • Joined on Thu, Oct 13 2005
    • Boston
    • Posts 2,444
    • Points 30,415
    • Avid Certified Instructors - Video
      Avid Employee
      Moderator: Film
      Moderator: MetaFuze

    Re: MetaFuze v1.2 Not Transcoding across all CPU cores

    Well... we have strict labor laws and the hiring of 8 years olds is pretty tough...   Wink

    I moderate the Avid section on the RED forum. And again, here like there, I can only speak to the reality of the process bound by the laws of a public company - inability to speak to products that release over the current quarter's boundary.

    Referring directly to MetaFuze - we know quite well the limitations of MetaFuze and are working on them. The batch transcode is known issue and is being addressed for the next release, and as of May 25th, 2009 it has not. v1.3 is not out yet. We "hope" and are working towards a release in a couple of weeks. In addition to the batch process we are adding:

    Filtering for input files
    Audio from R3D files
    Metadata alignment (SDK was a bit off...)
    Batch transcode
    Performance enhancement (all cores)

    And maybe... scripts to work with render farm management applications.

    Michael

    24p.com

  • Mon, May 25 2009 6:25 PM In reply to

    • lovis
    • Not Ranked
    • Joined on Mon, May 25 2009
    • Posts 4
    • Points 50

    Re: MetaFuze v1.2 Not Transcoding across all CPU cores

    Hello Michael,

    thanks for your answer and your consideration on those matter,

    I now understood reading "red user" complains that it was tough to be really competitive

    under a freeware frenchise.

    I hope to get the next release soon, except my red-avid-pc project is almost done, bad luck for me 'cause I lost many of my nights the past 30 days ;) so was my bad mood, but I feel better now!

    Have a nice and pleasant day,

    Byye

    Louis

  • Sun, Jul 5 2009 12:21 PM In reply to

    • o_ren
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Posts 19
    • Points 235

    Re: MetaFuze v1.2 Not Transcoding across all CPU cores

    Hi Michael

     

    Will the new MetaFuze be able to create ALE that can later be conformed (or at least somehow load) in RedCine?

    Will we finally be able to use MetaFuze for dailies???

     

     

    Thanks

  • Sun, Jul 5 2009 3:25 PM In reply to

    • MichaelP
    • Top 50 Contributor
    • Joined on Thu, Oct 13 2005
    • Boston
    • Posts 2,444
    • Points 30,415
    • Avid Certified Instructors - Video
      Avid Employee
      Moderator: Film
      Moderator: MetaFuze

    Re: MetaFuze v1.2 Not Transcoding across all CPU cores

    As I mentioned on RedUser - MetaFuze will include the directly level file name in the Camroll column that will help in these cases. But REDCINE's future is  mainly on hold as we wait to see what the REDCINE X application created by RED will do. Once we see what that application does - we will have a better sense of what the workflow will look like.

     

    Michael

    24p.com

Page 1 of 1 (11 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller