Latest post Sun, Nov 24 2019 12:57 PM by helmar7. 14 replies.
Page 1 of 1 (15 items)
Sort Posts: Previous Next
  • Sat, Oct 19 2019 8:10 AM

    • helmar7
    • Not Ranked
    • Joined on Wed, Jun 10 2015
    • Posts 13
    • Points 135

    Avid 2019.9 Performance Issues

    Hey all,

     

    i built a new System. Everything is freshly installed. 

    I have the problem that the Avid performance is a bit laggy when i go through the timeline, zoom in an out, i scroll through the bins, go to trim mode etc. i have nearly always a slightly lag (0.5 sec).

    I able to work with avid, but it really annoying me! 

     

    So some systemspecs:

    i9 7940x, system on ssd, 64gb ram, nvidia gforce 1070 (studio driver 430.86), avid 2019.9

     

    some more ideas would make me happy!

  • Sat, Oct 19 2019 12:06 PM In reply to

    Re: Avid 2019.9 Performance Issues

    What is your project format/frame rate, and what is your footage format/frame rate/file type? Does the problem happen with linked footage, or with media that has been transcoded/imported, or with all footage?

    Media Composer 2019.11 w/Symphony/SS/PF options, HP Envy 17t-j100 Quad Edition laptop, Windows 10 Pro, Intel Core i7 2.4GHz, 16 GB RAM, nVidia GeForce... [view my complete system specs]

    "There is hardly anything in the world that some man cannot make a little worse and sell a little cheaper, and the people who only consider the price are this man's lawful prey."  - John Ruskin (1819-1900)

     

    Carl Amoscato | Freelance Film & Video Editor | London, UK

  • Sat, Oct 19 2019 12:35 PM In reply to

    • helmar7
    • Not Ranked
    • Joined on Wed, Jun 10 2015
    • Posts 13
    • Points 135

    Re: Avid 2019.9 Performance Issues

    Seems to be a general problem!

    The one project is a dnxhd36  and no amas, the other a mixed project, both 25p 1080. So not really a big thing!

  • Sat, Oct 19 2019 2:30 PM In reply to

    • Erik
    • Top 500 Contributor
    • Joined on Thu, Oct 5 2006
    • Austin, TX
    • Posts 207
    • Points 2,465

    Re: Avid 2019.9 Performance Issues

    What display size and screen resolution are you using. These all sound like instances in which Avid has to redraw some of the interface.

    Try reducing your display resolution to see if that improves performance.

    MC 2019.9 Asus Prime X299 Deluxe, 64GB of Memory, Core i9 7940x @3.1Ghz, Nvidia GeForce GTX 1070 Ti. Running Win10 Pro 64bit MC 2018.4 Dell Precision... [view my complete system specs]
  • Sat, Oct 19 2019 3:00 PM In reply to

    Re: Avid 2019.9 Performance Issues

    Open the Console. While you edit, see if any error or warning appears. Post it here. 

    MC 2019.9, Windows 10, ASROCK X99M, Intel 5930K, Zotac RTX 2070 Super, 32GB RAM, Transcend 512GB M.2 SSD & Dell UP2718Q. MBP 2012 Thunderbolt, OSX... [view my complete system specs]
  • Sat, Oct 19 2019 3:54 PM In reply to

    • helmar7
    • Not Ranked
    • Joined on Wed, Jun 10 2015
    • Posts 13
    • Points 135

    Re: Avid 2019.9 Performance Issues

    Memory stats: physical = 65211 MB, virtual = 134217727 MB, restriction = 0 MB

    WARNING: Requested LocateBuffer size 2048MB is the same as current size 2048MB.

    Set persistent image cache limit: 200.0 MB in C:/Users/Public/Documents/Avid Media Composer/AvidImageCache

    WARNING: Requested LocateBuffer size 2048MB is the same as current size 2048MB.

    AWin32Mixer::Open inputMixerID = 4

    AWin32Mixer::Open - Failed to validate output mixer: outputMixerID 0 is invalid mixer

     

    Created ADM Device : 1394 Audio

    DirectSound ADM running on Windows OS Version Major=6 Minor=2 Build=9200

    AWin32Mixer::Open inputMixerID = 4

    AWin32Mixer::Open - Failed to validate output mixer: outputMixerID 0 is invalid mixer

     

    Created ADM Device : DirectSound Audio

    AlertableTimer Win32 constructor, default system clock resolution min = 1, max = 1000000

    AlertableTimer Win32 constructor, default system clock resolution min = 1, max = 1000000

    AlertableTimer Win32 constructor, default system clock resolution min = 1, max = 1000000

    MCBootstrap::gwhoami = 30

    Avid Media Access: Device monitor successfully initialized

    AVX Library V1.5

    OpenGL implementation found:

    vendor = Brian Paul

    renderer = Mesa OffScreen16

    version = 1.5 Mesa 6.4

    This OpenGL implementation does not support hardware texture render

    maximum render dimensions: = 1920 x 1080 at 8 bits per pixel channel

     

    OpenGL implementation found:

    vendor = NVIDIA Corporation

    renderer = GeForce GTX 1070/PCIe/SSE2

    version = 4.6.0 NVIDIA 430.86

    This OpenGL implementation supports hardware texture render

     

    maximum render dimensions: = 1920 x 1080 at 8 bits per pixel channel

     

    AME CPU Buffer Deallocator Registered Successfully

    AME GPU Buffer Deallocator Registered Successfully

    MonCon Painters: GPU, CPU

    ACPL Transfer Type: OGL

    ACPL Transfer Buffer Type: Persistent

    ACPL Transfer Mode: NonOverlapped

    ACPL GPU Memory Pool Capacity: 4096 MB

    ACPL GPU Memory Pool Host Capacity: 1952 MB

    ACPL GPU Private Memory Pool Capacity: 3584 MB

    ACPL GPU Private Memory Pool Host Capacity: 0 MB

    ACPL GPU VRAM Capacity: 8192MB

    Newer CPU<->GPU bus speeds detected (3.6025)

    AAF DLL loaded from : C:\Program Files\Avid\Avid Media Composer\AAFCOAPI.dll

    AAF DLL version : 2.0.6 (10030) [1]

    DFM loaded. 244 entries initialized. Scripts directory 'C:\Program Files\Avid\Avid Media Composer\SupportingFiles\CodecToolkit_Config\'

    Setting chained toggle /Q7Container/EnableInternalProcessing_H264:true

    Setting chained toggle /Q7Container/EnableInternalProcessing_AAC:true

    Setting chained toggle /Q7Container/EnableInternalProcessing_MJPEG:true

    Setting chained toggle /Q7Container/EnableInternalProcessing_TIFF:true

    Setting chained toggle /Q7Container/EnableInternalProcessing_JPEG:true

    Setting chained toggle /Q7Container/EnableInternalProcessing_PCM:true

    Setting chained toggle /Q7Container/EnableInternalProcessing_ProRes:false

    Setting chained toggle /Q7Container/EnableInternalProcessing_MPEG-2:false

    Setting chained toggle /Q7Container/EnableInternalProcessing_DNxHR:false

    Setting chained toggle /Q7Container/EnableInternalProcessing_DNxHD:false

    Setting chained toggle /Q7Container/EnableInternalProcessing_Alpha:true

    Setting chained toggle /Q7Container/EnableInternalProcessing_RLE:false

    Setting chained toggle /Q7Container/SupportMediaWithRoundedTrackLength:true

    Setting chained toggle /Q7Container/RedirectToQ7_26_IfAvailable:false

    Setting chained toggle /Q7Container/RedirectMediaWithRoundedTrackLengthToQ7_26_IfAvailable:false

    Setting chained toggle /Q7Container/Disable16BitImageFormatsSupport:false

    Setting chained toggle /GenericMXFContainer/MXFSuppressMCAMetadata:false

    Setting chained toggle /GenericMXFContainer/OverrideUnsupportedDistinguishedFrameLayout:true

    Setting chained toggle /Q7Container/TruncateMasterMobEssenceSlotsToMinumumCommonDuration:false

    Setting chained toggle /Q7Container/TreatVariableFrameRateAsConstantAverage:true

    Setting chained toggle /QuickTimeMediaContainer/TruncateFractionalStartOffsetsToFullFramePrecharge:true

    Setting chained toggle /AMPPlugin/Enable_DNx:true

    Setting chained toggle /AMAFI-SDK/DisableLoggingErrorMessagesOnContainerHandlerProbing:true

    Setting chained toggle /Q7Container/RedirectMediaWithMasterMobFillerToQ7_26_IfAvailable:false

    Setting chained toggle /AMPPlugin/Enable_DCP_J2K:false

    Setting chained toggle /AMPPlugin/Enable_IMF_J2K:true

    Setting chained toggle /AMPPlugin/Enable_J2K:true

    Setting chained toggle /AMPPlugin/Enable_DV_Based:true

    Setting chained toggle /AMPPlugin/Enable_CAT_AVCI:true

    Setting chained toggle /AMPPlugin/Enable_H264_Proxy:false

    Setting chained toggle /AMPPlugin/Enable_DNxU:true

    Setting chained toggle /GenericMXFContainer/SetDefaultLengthInStaticSlotComponents:true

    Setting chained toggle /GenericMXFContainer/EnableRedirectionToAvidOPAtom:false

    Setting chained toggle /WaveAiffReaderMovMediaContainer/AudioTimecodeUseBEXTOriginationDate:false

    Setting chained toggle /AMAFI-Tiff/TiffReturnCompressedEssence:false

    BigBufferPool 0x000000015BACACF0:

    Size: 2147483648 (2.00G)

    Total Free: 2147483648 (2.00G)

    Largest Free: 2147483648 (2.00G)

    Memory Chunk 0x0000000017273A50, ADDR=[0x00007FF3051F0000]

    Size: 2147483648 (2.00G)

    Total Free: 2147483648 (2.00G)

    Largest Free: 2147483648 (2.00G)

    Number Allocs: 0

    Max Allocs: 0

    MSM directories:1

    LocalMDB::LoadMobsFromMDB() inCallback=0000000000000000 sourceOnle=FALSE

    mediaDirPath phyMobs logMobs

    "C:\Users\Public\Documents\Avid Media Composer\Avid_MediaFiles\" 0.01 sec

    total time=0.01 mobs=0

    Media Drives:

    ASUS (B:), OSVolID = 66, 236156 totalKB, 0 freeKB, 0 realFreeKB

    Windows10SSD (C:), OSVolID = 67, 438917124 totalKB, 267886128 freeKB, 267362913 realFreeKB

    WorkSSd (E:), OSVolID = 69, 976744444 totalKB, 857916464 freeKB, 856240846 realFreeKB

    Ramtatata2 (F:), OSVolID = 70, 2930134012 totalKB, 2349317148 freeKB, 2344728638 realFreeKB

    Yeepeeyaa (G:), OSVolID = 71, 2930134012 totalKB, 1484228584 freeKB, 1481329701 realFreeKB

    Ohyeah (I:), OSVolID = 73, 2930134012 totalKB, 2642939928 freeKB, 2637777936 realFreeKB

    BigYiepeh (J:), OSVolID = 74, 11720980476 totalKB, 6766605812 freeKB, 6753389786 realFreeKB

    Schnabbidup (U:), OSVolID = 85, 9766418428 totalKB, 7660632408 freeKB, 7645670236 realFreeKB

    MAX_INDEXES_TO_READ set to 10240

    MXF Indexes in Memory changed to 524288000: Old Size 524288000

    In Init ARO Cmds

    MTSC state = 0The single frame player will be built for a length of 3600 frames

    Viewer: OpenCL and OpenGL are compatible

    MSMRescan() took: 0.593000s

    Set persistent image cache limit: 200.0 MB in C:/Users/Public/Documents/Avid Media Composer/AvidImageCache

    LocateBuffer Resize from 2048MB to 15360MB

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    CATException[80000008]codecs::FillCTVideoFormat, ..\..\CAT\core\extra\ctop.cpp:208 -> CAT_EXPECT_TRUE( width && height )

     

    Set persistent image cache limit: 200.0 MB in C:/Users/Public/Documents/Avid Media Composer/AvidImageCache

    WARNING: Requested LocateBuffer size 15360MB is the same as current size 15360MB.

    Set persistent image cache limit: 200.0 MB in C:/Users/Public/Documents/Avid Media Composer/AvidImageCache

    WARNING: Requested LocateBuffer size 15360MB is the same as current size 15360MB.

    The default render wait time is 50

    PreReads will bias DueTime by 0.000000 seconds.

    Reloading plugin: AudioCodecManager.avx

    Reloading plugin: CMAvidMPEG1Layer2AudioCodec.avx

    Warning: 16 audio clips required Audio SampleRate Conversion.

    Please convert these files to avoid underruns and improve audio quality.

    Warning: 16 audio clips required Audio SampleRate Conversion.

    Please convert these files to avoid underruns and improve audio quality.

    Set persistent image cache limit: 200.0 MB in C:/Users/Public/Documents/Avid Media Composer/AvidImageCache

    WARNING: Requested LocateBuffer size 15360MB is the same as current size 15360MB.

    Destroying Bin Container without closing

    Set persistent image cache limit: 200.0 MB in C:/Users/Public/Documents/Avid Media Composer/AvidImageCache

     

    WARNING: Requested LocateBuffer size 15360MB is the same as current size 15360MB.

     


    HERE the console! no really problems i guess!

  • Sat, Oct 19 2019 3:57 PM In reply to

    • helmar7
    • Not Ranked
    • Joined on Wed, Jun 10 2015
    • Posts 13
    • Points 135

    Re: Avid 2019.9 Performance Issues

    Hey,

     

    iam using a 16:10 Hd display and a 4k Monitor at 125% Windows zoom.... i tried to disconnect the 16:10 and set the 4k monitor to 100%... Micro freezes again!

  • Sat, Oct 19 2019 3:58 PM In reply to

    • helmar7
    • Not Ranked
    • Joined on Wed, Jun 10 2015
    • Posts 13
    • Points 135

    Re: Avid 2019.9 Performance Issues

     

    this is shown in the console !

     

    WARNING: Requested LocateBuffer size 15360MB is the same as current size 15360MB.

     

    is this a problem?

  • Sat, Oct 19 2019 5:32 PM In reply to

    • Erik
    • Top 500 Contributor
    • Joined on Thu, Oct 5 2006
    • Austin, TX
    • Posts 207
    • Points 2,465

    Re: Avid 2019.9 Performance Issues

    Just for experimentation, try changing your display resolution from 4k to 1920x1080. If that works well try a slightly higher resolution and continue in increments until it starts getting sluggish again.

     

    MC 2019.9 Asus Prime X299 Deluxe, 64GB of Memory, Core i9 7940x @3.1Ghz, Nvidia GeForce GTX 1070 Ti. Running Win10 Pro 64bit MC 2018.4 Dell Precision... [view my complete system specs]
  • Sat, Oct 19 2019 5:59 PM In reply to

    Re: Avid 2019.9 Performance Issues

    Have you tried the standard Nvidia drivers instead of the Studio version?

    MC 2019.9, Windows 10, ASROCK X99M, Intel 5930K, Zotac RTX 2070 Super, 32GB RAM, Transcend 512GB M.2 SSD & Dell UP2718Q. MBP 2012 Thunderbolt, OSX... [view my complete system specs]
  • Sat, Oct 19 2019 6:26 PM In reply to

    • helmar7
    • Not Ranked
    • Joined on Wed, Jun 10 2015
    • Posts 13
    • Points 135

    Re: Avid 2019.9 Performance Issues

    Will test it tomorrow.

     

    and yeah i was on the standard driver before!

  • Sun, Oct 20 2019 8:28 AM In reply to

    • helmar7
    • Not Ranked
    • Joined on Wed, Jun 10 2015
    • Posts 13
    • Points 135

    Re: Avid 2019.9 Performance Issues

    Wow, it seems to be really the problem.. when i  go on the 4k display to HD the performance increases! when i go to 2k its sluggish again. Do u know a solution for thisa problem? or have i think about a new graphic card?

     

    king regards

  • Sun, Oct 20 2019 1:04 PM In reply to

    • Erik
    • Top 500 Contributor
    • Joined on Thu, Oct 5 2006
    • Austin, TX
    • Posts 207
    • Points 2,465

    Re: Avid 2019.9 Performance Issues

    As others have suggested, you might try changing the graphics driver.

    How much video memory is on your card?

    I have a GTX 1070 TI 8GB, running driver version 419.67 (which is an older version) and do not notice any performance issues with running a 4k display at 4k and 150% scaling. 

     

    MC 2019.9 Asus Prime X299 Deluxe, 64GB of Memory, Core i9 7940x @3.1Ghz, Nvidia GeForce GTX 1070 Ti. Running Win10 Pro 64bit MC 2018.4 Dell Precision... [view my complete system specs]
  • Sun, Oct 20 2019 1:55 PM In reply to

    • helmar7
    • Not Ranked
    • Joined on Wed, Jun 10 2015
    • Posts 13
    • Points 135

    Re: Avid 2019.9 Performance Issues

    i will try.

     

    is nearly the same without the TI :)

     

    The other driver was not solving my prob.. just tried a bit the HD resolution... not really better :(

     

    UPDATE:

     

    I have now a geforce 2070 Super and i have the same performance probs since before... i dont really know what to do now., the lagging is really making my aggresiv :)

     

    Some more ideas?

  • Sun, Nov 24 2019 12:57 PM In reply to

    • helmar7
    • Not Ranked
    • Joined on Wed, Jun 10 2015
    • Posts 13
    • Points 135

    Re: Avid 2019.9 Performance Issues

    So for everybody who is interested.

     

    So the final solution was to change the mainboard from asus to supermicro and got a better graphiccard  (geforce gtx 1080 ti, 11gb) and finally get two 4k monitors (earlier it was HD + 4k).

     

    Thank u for all replies!

Page 1 of 1 (15 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller