Latest post Fri, May 17 2019 1:11 PM by Rich Laws. 5 replies.
Page 1 of 1 (6 items)
Sort Posts: Previous Next
  • Tue, May 14 2019 3:29 PM

    Dependency issue with mediaprocessor-win-vc14-x64-4.4.25.10050

    We ran into an issue with package when installed on a clean system.  It seems that one of the DLLS included with latest VC14 release of media processors is dependant on the VS 2013 c++ lib support.

    According to a dependancy walker - FTF.DLL (dated 2016-10-13) is dependant on MSVCR120.DLL and MSVCP120.DLL.

    When installing on a clean system, this library fails to load - our installer is not explicity including the 2013 libraries any longer.  Can this be resolved in a future release?

    Thanks,

    Rich Laws

     

  • Thu, May 16 2019 12:38 PM In reply to

    Re: Dependency issue with mediaprocessor-win-vc14-x64-4.4.25.10050

    As a note, in the newly release distribution: mediaprocessor-win-vc14-x64-4.4.28.10055, FTF.DLL still has a VC++ 2013 runtime dependency in the 2015 version.  (requires installers to include VC 2013 support).  Let me know if this cannot be changed and I wil make sure that our installers provide VC2015 and VC2013 lib support.

    Thanks!

    Rich

  • Fri, May 17 2019 12:42 PM In reply to

    • andym
    • Not Ranked
    • Joined on Thu, Jan 13 2011
    • Posts 111
    • Points 1,345
    • Avid Developer Moderator

    Re: Dependency issue with mediaprocessor-win-vc14-x64-4.4.25.10050

    Rich, we'll be looking into this in one of our upcoming sprints. This is an external dependency.

  • Fri, May 17 2019 1:05 PM In reply to

    Re: Dependency issue with mediaprocessor-win-vc14-x64-4.4.25.10050

    Hi Rich,

    Thank you for letting us know.  We have this issue logged and hope to address it in an upcoming release. 

     

    Best Regards,

    Dennis

     

  • Fri, May 17 2019 1:09 PM In reply to

    Re: Dependency issue with mediaprocessor-win-vc14-x64-4.4.25.10050

    Hi Andy,

    Thanks for the response.  I was guessing that it was an external library.  We can workaround this in the meantime.

    Rich

  • Fri, May 17 2019 1:11 PM In reply to

    Re: Dependency issue with mediaprocessor-win-vc14-x64-4.4.25.10050

    Hi Dennis

    Thank you for the follow up.  It is an issue that we can workaround by including the needed MS library in our installer package. My inquiry was more informational for the team.   Should I still log through support portal?

    Rich

Page 1 of 1 (6 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller