Latest post Thu, May 9 2019 10:29 AM by pablo garcia. 0 replies.
Page 1 of 1 (1 items)
Sort Posts: Previous Next
  • Thu, May 9 2019 10:29 AM

    help! Does anyone have the old version 2.2 or 2.3 of Avid Router Control?

    Hi, for reasons of compatibility of my Interplay system, I would need an old version of Avid Router Control. Only 2.2 and 2.3 would be valid. Avid does not have them.  If someone had any of them, it would be of great help to me. Thank you

Page 1 of 1 (1 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller