Latest post Wed, May 15 2019 10:36 AM by matev. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • Tue, May 7 2019 8:19 AM

    • matev
    • Not Ranked
    • Joined on Tue, Aug 2 2016
    • Posts 8
    • Points 90

    Installing bus service feature pack

    Hi All,

    We are trying to install a bus service to cloudux 2019.2. The service was cerated in App Creator Tool in VS Code with cloudux-starter-kit-service@2.0.2. After uploading the feature pack to the server we execute commands

    avidctl feature-pack import service.zip

    and

    avidctl feature install --feature avid-releases/service --name service --version=1

     

    The second command fails with

    Error: render error in "service/templates/deployment.yaml": template: service/templates/deployment.yaml:19:28: executing "service/templates/deployment.yaml" at <include (print $.Tem...>: error calling include: template: service/templates/config.yaml:13:13: executing "service/templates/config.yaml" at <.Values. service .env>: can't evaluate field env in type interface {}

    exit status 1

     

    Do you know where can be the problem? Installing other a UI App with the same commands is working, the problem is only with bus services.

     

    Thanks and Best Regards

     

    BTW. The App Creator Tool stopped working with the newest version of VS Code on macOS and windows also.

  • Tue, May 7 2019 8:15 PM In reply to

    • Vadym
    • Top 500 Contributor
    • Joined on Thu, Apr 17 2014
    • Posts 216
    • Points 2,655
    • Avid Developer Moderator
      Avid Employee

    Re: Installing bus service feature pack

    Hi Mate,

    I'd recommend to try with a basic sample service and see if that works for you. If this is something in your actual service I'd need the feature pack for investigation. It may be an offending environment variable or something else.

     

    Thanks for letting us know about VS Code breaking changes, will look into it.

  • Wed, May 15 2019 10:36 AM In reply to

    • matev
    • Not Ranked
    • Joined on Tue, Aug 2 2016
    • Posts 8
    • Points 90

    Re: Installing bus service feature pack

    Hello Vadym,

    Thank you for your answer. The problem was that our service had not had a configuration yaml file. Even if the file and env variables in it are not used by our service, the file must exist and contain some basic keys.

    Best Regards

Page 1 of 1 (3 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller