Latest post Thu, Jul 18 2019 5:34 PM by www.drastic.tv. 11 replies.
Page 1 of 1 (12 items)
Sort Posts: Previous Next
  • Tue, Apr 16 2019 12:23 AM

    • bruce74
    • Not Ranked
    • Joined on Mon, May 18 2015
    • Posts 12
    • Points 140

    TaggedValues in AMTv3

    Hi,

     

    Has anyone had any success with adding TaggedValues (ie UserComments) to a MAD that would then be in the exported AAF and MXF OP-Atom files?

     

    It seems that in the MediaAssetDescription.xsd that this is possble - however I can't get it to work - (seems like it's just ignored) - using 4.4.23.10046 on Windows and macOS - so wondering what I could be doing wrong

     

    Thanks

    Bruce

  • Fri, Apr 19 2019 1:28 PM In reply to

    • Vadym
    • Top 500 Contributor
    • Joined on Thu, Apr 17 2014
    • Posts 224
    • Points 2,715
    • Avid Developer Moderator
      Avid Employee

    Re: TaggedValues in AMTv3

    Hi Bruce,

    I've followed up on this internally and it is not currently enabled, but we have it on the backlog, but no target date for release yet.

  • Fri, Apr 19 2019 1:41 PM In reply to

    • bruce74
    • Not Ranked
    • Joined on Mon, May 18 2015
    • Posts 12
    • Points 140

    Re: TaggedValues in AMTv3

    Hi Vadym,

     

    Cool - thanks for the info.

     

    Also - just seeing if you had any info on another post I had

     

    http://community.avid.com/forums/t/196729.aspx

     

    specifically - the below this question



    (1) What's the minimal libraries needed to install with our app for just re-wrapping - it seems that when we  start up the MediaProcessor in our app that it tries to load all the AMA plugins and in the Avid MC plugins directory too  (based on looking at the output window in VS Studio and the Console in macOS)

    Basically - We'd only want to include the libraries needed for re-wrapping and not have the SDK trying to load AMA plugins from the Avid installation.

     

     

    Thanks in advance!

  • Fri, May 3 2019 5:13 PM In reply to

    • andym
    • Not Ranked
    • Joined on Thu, Jan 13 2011
    • Posts 111
    • Points 1,345
    • Avid Developer Moderator

    Re: TaggedValues in AMTv3

    As posted in http://community.avid.com/forums/t/196903.aspx, AMT3 support for custom metadata as TaggedValue is expected for the next release.

    If AMT3 is co-located with a MediaComposer installation, by default it will attempt to load the AMA plugins installed under the shared C:\Program Files\Avid\AVX2_Plug-ins path. We are checking whether there is a way of modifying this behavior.

  • Thu, May 9 2019 2:20 PM In reply to

    • bruce74
    • Not Ranked
    • Joined on Mon, May 18 2015
    • Posts 12
    • Points 140

    Re: TaggedValues in AMTv3

    Cool - thanks for the info. It'd be great to have a minimal load as possible when only using the rewrapping functionality of AMTv3

  • Wed, Jul 17 2019 4:13 PM In reply to

    Re: TaggedValues in AMTv3

    Hi Andy

      Has this been released yet?  I am using version 4.4.23.10046.  I have added some tagged values to my MAD like this

    <?xml version="1.0" encoding="UTF-8" standalone="no" ?>

    <mpmad:MediaAssetDescription xmlns:mpmad="urn:AVID:MediaProcessor:MediaAssetDescription" xmlns:mpct="urn:AVID:MediaProcessor:CommonTypes" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="urn:AVID:MediaProcessor:MediaAssetDescription MediaAssetDescription.xsd">

    <mpmad:StartTimecode>

    <mpct:RoundedTimecodeBase>30</mpct:RoundedTimecodeBase>

    <mpct:FrameCounter>300</mpct:FrameCounter>

    <mpct:DropFrame>false</mpct:DropFrame>

    </mpmad:StartTimecode>

    <mpmad:TaggedValues>

    <mpmad:TaggedValue>

    <name>Scene</name>

    <value>003</value>

    </mpmad:TaggedValue>

    <mpmad:TaggedValue>

    <name>Comment</name>

    <value>This is a comment</value>

    </mpmad:TaggedValue>

    <mpmad:TaggedValue>

    <name>Comments</name>

    <value>This is a comments</value>

    </mpmad:TaggedValue>

    <mpmad:TaggedValue>

    <name>Description</name>

    <value>This is a comments</value>

    </mpmad:TaggedValue>

    <mpmad:TaggedValue>

    <name>Camera</name>

    <value>Drastic Camera</value>

    </mpmad:TaggedValue>

    </mpmad:TaggedValues>

    <mpmad:MaterialName>NewFileMobIDcomment</mpmad:MaterialName>

    </mpmad:MediaAssetDescription>

    But I am not seeing them in the AAF or anywhere beyond

     

    Cheers, James

  • Wed, Jul 17 2019 5:10 PM In reply to

    • bruce74
    • Not Ranked
    • Joined on Mon, May 18 2015
    • Posts 12
    • Points 140

    Re: TaggedValues in AMTv3

    Hi

     

    Try

     

    <mpmad:Name></mpmad:Name>

     

    and

    <mpmad:Value></mpmad:Value>

     

     

    that works for us

     

    Cheers

    Bruce

  • Thu, Jul 18 2019 2:37 PM In reply to

    Re: TaggedValues in AMTv3

    Thanks Bruce!

     

      You are absolutely correct, of course :), I fogot to properly scope those tags.  Unfortunately, that change did not work here.  We are placing the tags in the MAD before we start the AMT3 writing, at the same level and between the StartTimecode and the MaterialName tags.  Is that the same as what you are doing?

     

    Cheers, James

  • Thu, Jul 18 2019 2:56 PM In reply to

    • bruce74
    • Not Ranked
    • Joined on Mon, May 18 2015
    • Posts 12
    • Points 140

    Re: TaggedValues in AMTv3

    You're welcome - yes that's where we're placing it in the MAD and it works fine here - shows up in the AAF and shows in Avic MC to when AAF and MXFs are imported into Avid MC Bin.

     

    We're using 4.4.28.10055

  • Thu, Jul 18 2019 3:04 PM In reply to

    Re: TaggedValues in AMTv3

    Thanks again.  Looks like your SDK is a little ahead of ours.  I will see if we can get an update.

     

    Cheers, James

  • Thu, Jul 18 2019 3:16 PM In reply to

    • bruce74
    • Not Ranked
    • Joined on Mon, May 18 2015
    • Posts 12
    • Points 140

    Re: TaggedValues in AMTv3

  • Thu, Jul 18 2019 5:34 PM In reply to

    Re: TaggedValues in AMTv3

    I can confirm, it works as Bruce says, so long as you are using the 4.4.28.10055 SDK (or greater presumably)

    Idea

Page 1 of 1 (12 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller