Latest post Tue, Oct 23 2018 10:04 AM by andym. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • Tue, Oct 16 2018 9:23 PM

    • Simon Tang
    • Not Ranked
    • Joined on Thu, Oct 4 2018
    • Posts 3
    • Points 35

    Credential error connecting to interplay

    We are integrating the AMT3 SDK to create AAF+MXF files and check them into Interplay.  However we are getting errors doing this, so first we are now trying to simply connect to Interplay to simplify the situation.

    We are trying to connect to Interplay and list the attributes, by following the code/instructions from:
    InterplayProductionWebServicesinCSharp-250418-2055.pdf

    From Visual Studio, we can add a service reference to this:
    http://z4/services/Assets?wsdl

    Note that this only seems to work if Visual Studio itself is running on our 'z4' machine.

    Then, trying to log in fails with this error:
    Unable to login user CapellaTest to workgroup AvidWG
    The username or password is incorrect

    I am using the username/password set up in Avid Interplay Administrator, under 'User Management'.  User has read/write/delete access.

    Our rough system setup is:
    z4:
        Avid Interplay Wed Services 2018.9.0.61515
        Avid Application Manager 18.4.3.18185
        Avid NEXIS client 18.6.1.14

    10.0.0.25 (Win-t7po4fvsrcf)
        Avid Interplay Access
        Avid Interplay Administrator
        Avid NEXIS client manager

    10.0.0.99 (WIN-2PRR87NUDBU)
        Avid ISIS

    Is there any log or anything I should double-check?

    Filed under: ,
  • Tue, Oct 16 2018 9:58 PM In reply to

    • Simon Tang
    • Not Ranked
    • Joined on Thu, Oct 4 2018
    • Posts 3
    • Points 35

    Re: Credential error connecting to interplay

    Note that on the same machine (z4), if I go to http://localhost/ I see the 'Avid Interplay WS Documentation'. 

    If I do 'Test Configuration' there, I also get the same credentials error.

    So it seems like a system setup issue, but I'm not sure which user name/password/workgroup to use or where that's configured.  I did add users wherever I could which matched the username/password used here, but with no success.

  • Tue, Oct 23 2018 10:04 AM In reply to

    • andym
    • Not Ranked
    • Joined on Thu, Jan 13 2011
    • Posts 102
    • Points 1,200
    • Avid Developer Moderator

    Re: Credential error connecting to interplay

    Simon,

    we recommend to explore 'Interplay Web Services' functionality with a tool like SOAPUI (https://www.soapui.org/) to ensure you can successfully perform elementary operations such as check-in. The AMT3 notification mechanism for SOAP talks to the same API but with AMT as an intermediate layer which can make it difficult to understand even simple error scenarios.

    With SOAPUI or similar tools you can download the WSDL for the IPWS 'Assets' service realm and have SOAPUI create vanilla requests for you that you can then explore interactively. You should specifically try the 'CheckinAAF' call which is what AMT3 uses to check in the AAF metadata for the clip it creates. Note that this operation may require an Avid shared storage environment to be available. Once you have the direct operation working, you can use the same credentials and connection string to configure AMT notifications.

Page 1 of 1 (3 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller