Latest post Thu, Aug 20 2015 11:07 AM by OleksiiK. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • Thu, Aug 20 2015 10:56 AM

    • Vijeta
    • Not Ranked
    • Joined on Tue, Jul 8 2014
    • Posts 7
    • Points 105

    DNxHR library support for machines not having SSSE3.1 instruction set

    Hi,

    We are using DNxHR.lib and DNxHR.dll for decoding of DNxHD content.
    Everything works fine on Intel Processor machines. But on AMD machines, on
    which we don't have SSSE3.1 instruction sets, our application is getting
    crashed, with message in EventViewer, having faulting module as DNxHR.dll

    Can we use DNxHR's libs on machines which dont support SSSE3.1 instruction set,
    If not is there any work around for the same.

    Best Regards,
    Vijeta

    Filed under:
  • Thu, Aug 20 2015 11:07 AM In reply to

    • OleksiiK
    • Not Ranked
    • Joined on Mon, Dec 23 2013
    • Posts 25
    • Points 270
    • Avid Developer Moderator

    Re: DNxHR library support for machines not having SSSE3.1 instruction set

    Hello Vijeta,

    Update SDK to version 2.2 and use

    • DNxHR.lib for dynamic SDK with static C++ runtime.
    • DNxHRs.lib for static SDK with dynamic C++ runtime.
    • or DNxHRs_srt.lib for static SDK with static C++ runtime.
    Please ignore files with 'ssse3' in their names. Oleksii.

Page 1 of 1 (2 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller