Latest post Fri, Jan 10 2020 4:26 PM by Michael Watts. 8 replies.
Page 1 of 1 (9 items)
Sort Posts: Previous Next
  • Fri, Apr 17 2015 8:32 AM

    • Francesco
    • Not Ranked
    • Joined on Wed, May 16 2012
    • Pisa - Italy
    • Posts 69
    • Points 680

    Error exporting

    Hi

    in these days we are testing our plugin with latest version of MediaComposer (8.3.1).  In exporting material there is an error:

    @ Fri Apr 17 10:27:14 2015

    * Exception: std::exception, what:ACF call failed: sampleConsumer->Setup (trackIndex, 0), error code 0x80000001, file ..\..\src\AMAExport\AMAExportMedia.cpp line 64


    Any suggestion ?

    regards

    Filed under: , ,
  • Tue, Apr 21 2015 10:24 AM In reply to

    • Francesco
    • Not Ranked
    • Joined on Wed, May 16 2012
    • Pisa - Italy
    • Posts 69
    • Points 680

    Re: Error exporting

    Hi

    I found solution.  The anomaly borns in SampleConsumer::Setup method.  Up to AVID Media Composer 7.5 returning ACF_E_NOTIMPL doesn't create problems.  Seems that whit version greater than 8.3.0 this generate the reported error.  I solved returning  ACF_OK.

    regards


  • Wed, Apr 22 2015 1:12 PM In reply to

    Re: Error exporting

    Hi Francesco,

    Yes, we've seen this happen with several AMA plug-ins that initially only implemented what was immediately necessary, only to be surprised when a new version of the AMA-enabled application (Media Composer, ProTools, Media Director) flagged the unimplemented functions.

    To help prevent this we provide an AMAValidator that exercises your plug-in's AMA interfaces (for AMA linking, sample-provider/sample-mapping, but not yet the AMA export functionality).  I will send you a follow-up email with the details.

    - Don

  • Sat, May 26 2018 7:17 PM In reply to

    • kaspar65
    • Not Ranked
    • Joined on Sun, May 20 2018
    • Posts 3
    • Points 25

    Re: Error exporting

    Hi, i red your post and I was intersted in the solution

    I have same error acf but i cant understand how to fix it

    if you can help i'd appreciate

    thanks

    marcello

  • Thu, Jan 9 2020 10:20 PM In reply to

    • Michael Watts
    • Not Ranked
    • Joined on Tue, Sep 15 2015
    • Alexandria, VA
    • Posts 5
    • Points 65

    Re: Error exporting

    Hi Don.  I am having a similar issue and am hoping the AMAValidator would help, even though I'm not exactly sure what it is.  Could you please email me or reply in the forum with details.

     

    Thanks very much!

     

    Running MC 2019.12 on 2019 iMac

    OS 10.14.6

    3.6 GHz Intel Core i9

    128 GB Ram

    Radeon Pro Vega 28 8 GB

     

    2019 27" iMac Retina 5K 3.6 GHz Intel Core i9 128 GB Ram 2667 MHz DDR4 Radeon Pro Vega 48 8 GB [view my complete system specs]
  • Thu, Jan 9 2020 11:01 PM In reply to

    • mikedeluca
    • Not Ranked
    • Joined on Tue, Feb 28 2017
    • Posts 7
    • Points 85

    Re: Error exporting

    Michael,

    Can you be more specific about the nature of the error?  The previous posts with any detail are from 2015.

    Thanks

  • Thu, Jan 9 2020 11:41 PM In reply to

    • Michael Watts
    • Not Ranked
    • Joined on Tue, Sep 15 2015
    • Alexandria, VA
    • Posts 5
    • Points 65

    Re: Error exporting

    Essentially there is an older sequence that will load but will not play.  While I can still navigate around media composer aftre loading it, bins and windows will open but will not function and do not close.  I have gone through the sequence in question and tried to isolate an individual clip that could the the issue but it gets constantly stuck to where I cannot do anything in the sequence.  The entire sequence has been transcoded but it still seems like it didn't transcode all the audio clips.  I can't figure out how to copy and paste the pop up error message so I'll type most of it out, but it is very similar to the one that began this string.  

     

    Exception: std::exception, what:ACF call failed: _pUncompresasedAudioProvider->GetAudioFormat( a long list of things int parenthesis), =error code 0x80000001, file /Builds/Workspace/MC/Release_Installer_Git

    2019 27" iMac Retina 5K 3.6 GHz Intel Core i9 128 GB Ram 2667 MHz DDR4 Radeon Pro Vega 48 8 GB [view my complete system specs]
  • Fri, Jan 10 2020 2:28 AM In reply to

    • mikedeluca
    • Not Ranked
    • Joined on Tue, Feb 28 2017
    • Posts 7
    • Points 85

    Re: Error exporting

    Michael,  OK. That is helpful.  Is there any part of your workflow that involves the "Error Exporting?"  Are you eventually going  to want to export the sequence that will not play?  Also, can you tell me what type of clips are involved or which AMA plug-in is involved?  I'm asking becuase this forum is about "Avid AMA Developers."  Thanks again.

  • Fri, Jan 10 2020 4:26 PM In reply to

    • Michael Watts
    • Not Ranked
    • Joined on Tue, Sep 15 2015
    • Alexandria, VA
    • Posts 5
    • Points 65

    Re: Error exporting

    Sorry, I didn't notice this was a particular forum, but as the issue could be with AMA maybe I am in the right place anyway.  To answer your question though, I was trying to work within the problem sequence for eventual export but since I kept getting the error message I transfered over what I could into a new sequence that is working OK.  That said, it would be much much easier to work out of the original sequence as I still need many of the elements I have been unable to transfer over.  There is another issue I've had with this particular project with MC locking up and freezing for 20 - 30 seconds at a time, at random intervals.  I filed a support case on this that, after a few weeks, went unresolved.  Since much of the media in question was AMA linked about 2 years ago I was thinking that might be a cause of the issues with this sequence, and research on the error code led me to this string.  Thanks again for any advice or guidance you might have!

    2019 27" iMac Retina 5K 3.6 GHz Intel Core i9 128 GB Ram 2667 MHz DDR4 Radeon Pro Vega 48 8 GB [view my complete system specs]
Page 1 of 1 (9 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller