Latest post Wed, Sep 11 2013 9:59 PM by kimncris. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • Tue, Aug 13 2013 1:20 AM

    • Isaquit0
    • Top 500 Contributor
    • Joined on Mon, Jan 9 2006
    • New York
    • Posts 211
    • Points 2,405

    Solved: Crash on Transcoding Spanned AVCHD Clips

     

    Hey Forum,

    I was transcoding an AVCHD volume via AMA Link when this showed up:

    Assertion failed: audioDesc && (0 < audioDesc->GetNumChannels())

    Clicking [Exit Application] eventually displayed an OSX app crash dialog.  You know, the one with the exceptions and hex dumps.

    Happened a couple times on the same clip. The same 27-minute clip.

    That's when it dawned on me: this might be a spanned clip. Doing a Reveal File (right-click on a clip -> Reveal File) showed two clips highlighted in Finder. Checked my bin. There's 0003, there's 0005, but where's 0004? Back to Finder. 0003's a ilttle over 4GB, 0004's 230-some MB. Yep, this is definitely a spanned clip.

    Looked up spanned clips in Help. It says they're supported, but how?

    Try this:

    1) Grab tsMuxeR.

    2) Get rid of the Korean fonts per the README. (I copied them to my Desktop to a folder, just in case.)

    3) Under Input, "add" the largest clip first, then "join" subsequent ones. (You'll see these buttons in tsMuxeR.)

    4) Select "M2TS Muxing" under Output.

    5) Import the M2TS directly into MC.

    I imported mine with DNxHD 100, compared it to the source footage, looks good.

    So next time you get this, check for long clips. Chances are they're spanned clips. Skip transcoding those for the first round, merge them into new M2TS's, import directly, and go.

    Good night!

     

    Mid-2010 Mac Pro • A Hackintosh [view my complete system specs]
  • Wed, Sep 11 2013 9:59 PM In reply to

    • kimncris
    • Not Ranked
    • Joined on Thu, Sep 5 2013
    • Posts 4
    • Points 30

    Re: Solved: Crash on Transcoding Spanned AVCHD Clips

    I had the same exact error.  Happens on any clip longer than about 4 mins.  My workaround was to use XDCam transfer "import" tool to join the long clips into one file before importing into avid.  Worked fine after doing that extra step.

Page 1 of 1 (2 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller