Latest post Sat, Jun 29 2013 11:15 AM by Wim Van den Broeck. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • Sat, Jun 29 2013 11:10 AM

    • Tempus2
    • Not Ranked
    • Joined on Sat, Jun 22 2013
    • Posts 1
    • Points 15

    M-Audio FastTrack C600 and Windows 8

    I've been wanting to use Windows 8 since I tried it the first time last fall, but my Fast Track C600 didn't work very well with it, so I had to use my old M-Audio Delta Audiophile cards in order to get any sound at all. I haven't seen any updates for drivers for this unit since then, but I decided to give Windows 8 and the Fast Track C600 another shot. Of course when everything was installed, the Fast Track C600 did not work properly, however, I found out I could get system sounds and also run my audio applications with Direct X, which was not the case back when I tried it the first time. ASIO just failed as last time. I've been tracing forums around to see if someone had a solution to this, and all I could find was that some users have reported success using the M-Audio Fast Track Pro with Windows 8.

    Despite the change-log of the Fast Track C600 drivers which says nothing about core-adjustments, but rather stuff about localization, I decided to try the old drivers found on M-Audio's page, version 1.0.1. And to my suprise, this driver let me use my audio-apps with ASIO. I've been waiting almost a year for this to happen, and now it finally works. I am over to Windows 8 permanently with a working Fast Track C600 combined with my old M-Audio Delta Audiophile cards, which seems to boost DSP and/or input-processing. Either because latency with and without is defenatly noticeable.

     

    I just wanted to let people that have trouble with the Fast Track C600 drivers and Windows 8, that there is a possibility to use the on-release drivers (1.0.1) rather than the newest (at this time 1.0.2) drivers when using Windows 8.

    Filed under: , , ,
  • Sat, Jun 29 2013 11:15 AM In reply to

    Re: M-Audio FastTrack C600 and Windows 8

    Hi,

     

    This is the Avid Video Community.

    You will have better luck posting your questions in the Avid Audio Forums: http://duc.avid.com/

     

    hth 

    Social Media Manager at Avid
    Editor-in-Chief avidblogs.com

    Got a great story to tell for #TimelineTuesday?
    Want to share a Media Composer Tutorial on #TutorialThursday?
    Contact me!

    Twitter: @editorbelga
    Facebook: fb.com/editorbelga 
    WWLD

     

Page 1 of 1 (2 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller