Avid Media Composer - PC

Forum for advanced Media Composer PC users.
Write a New Post
Page 1 of 1509 (30173 items) 1 2 3 4 5 Next > ... Last »
Announcements and FAQs
Announcement - post is pinned and allows no replies
START HERE - Posting Suggestions & General Information
by camoscato , Fri, Mar 26 2010 3:00 PM
Topics Replies Views
Popular Post pinned
Looking for the Latest Patches? by Larry Rubin
» Latest post by Hugh Moore , Sun, Aug 10 2014 1:45 AM
1, 2, 3, 4, 5, 6
75 75,542
Popular Post pinned
Media Composer 8.2.2 NOW AVAILABLE by camoscato
» Latest post by mkj , Fri, Feb 6 2015 7:36 AM
1 608
Popular Post
Exception: MSM: No directory specified_3 by dixie
» Latest post by yon1 , Thu, Feb 26 2015 10:29 PM
8 4,921
Post
Symphony 7.03 locks up when trying to slip video clip with a data... by bwaz
» Latest post by bwaz , Thu, Feb 26 2015 8:58 PM
0 35
Popular Post
Bin opening in MC 8.1 takes very long by Leeloo89
» Latest post by George Loco Angeludis , Thu, Feb 26 2015 8:57 PM
11 895
Post
Avid hangs on 'preparing to export', but does eventually export by Silverglade
» Latest post by bonang , Thu, Feb 26 2015 8:50 PM
1 61
Post
Color space issues by cesaromar
» Latest post by cesaromar , Thu, Feb 26 2015 8:14 PM
0 51
Popular Post
Captioning by cheknews
» Latest post by joshdvx , Thu, Feb 26 2015 6:15 PM
1, 2
16 690
Popular Post
Day for night? by bushfilm
» Latest post by bushfilm , Thu, Feb 26 2015 6:14 PM
2 212
Popular Post
Sample plot / waveform - strange behavior by sheriff
» Latest post by jef , Thu, Feb 26 2015 6:12 PM
5 471
Post
Error Message MC8.3 when press play by Michael from cologne
» Latest post by Michael from cologne , Thu, Feb 26 2015 3:04 PM
0 79
Popular Post
output to HDCAM-SR 444 from NitrisDX causes error message by cigordon
» Latest post by AldoBoccolari , Thu, Feb 26 2015 1:28 PM
3 808
Post
Ama relink issue by sashadays
» Latest post by sashadays , Thu, Feb 26 2015 12:28 PM
0 98
Post
Uninstall issue by Richard Browne
» Latest post by Richard Browne , Thu, Feb 26 2015 11:36 AM
2 148
Popular Post
Virus warning with MC 8.3 by jwrl
» Latest post by Mondo , Thu, Feb 26 2015 5:39 AM
1, 2
22 1,283
Post
hp z840 + Aja io4K Multicam Playback Issues by huunab
» Latest post by Mondo , Thu, Feb 26 2015 1:38 AM
3 176
Popular Post
Trim to Fill not working on clips with color adapters? by jrhagan33
» Latest post by Marianna , Wed, Feb 25 2015 9:32 PM
4 318
Post
Foreign Script Display by 4mylgl6
» Latest post by 4mylgl6 , Wed, Feb 25 2015 4:22 PM
0 81
Post
HP Computer Question by jmc7330
» Latest post by Kevin Klimek , Wed, Feb 25 2015 3:39 PM
1 180
Write a New Post
Page 1 of 1509 (30173 items) 1 2 3 4 5 Next > ... Last »
More Options

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller