Avid Media Composer - Mac

Forum for advanced Media Composer Mac users.
Write a New Post
Page 1 of 1012 (20233 items) 1 2 3 4 5 Next > ... Last »
Announcements and FAQs
Announcement - post is pinned and allows no replies
Idea [I] Get Started Fast w/ Media Composer | Software
by Marianna , Tue, Jun 10 2014 10:11 AM
Announcement - post is pinned and allows no replies
START HERE - Posting Suggestions & FAQs
by Kevin Klimek , Tue, Aug 10 2010 4:48 PM
Announcement - post is pinned and allows no replies
Tutorials and Guides
by Marianna , Sat, Jul 2 2011 6:47 PM
Topics Replies Views
Popular Post pinned
Idea [I] OS X Media Drive Permissions Issues by Todd Sanderson
» Latest post by mivko , Wed, May 21 2014 9:52 AM
1, 2, 3, 4
47 45,630
Popular Post pinned
Media Composer | Software -- Release 8.2 Available! by Kevin Klimek
» Latest post by MG , Tue, Oct 21 2014 2:24 PM
3 874
Post
Mirror Avid Project by ThomasJB
» Latest post by ThomasJB , Thu, Oct 23 2014 10:40 AM
0 12
Popular Post
8.2 Bug? Exception: A serious error Macbook Pro by Dennis
» Latest post by mjolnarn , Thu, Oct 23 2014 7:46 AM
1, 2
28 1,048
Post
Importing multiple audio tracks by Dwight
» Latest post by Mondo , Thu, Oct 23 2014 4:52 AM
1 78
Popular Post
8.2 crashes upon entering "Multicam Mode" by Robert Goodman
» Latest post by Robert Goodman , Thu, Oct 23 2014 2:28 AM
14 389
Post
Wrong Format error after AMA link to ExCam folder by Sisterrat
» Latest post by usatraveler , Thu, Oct 23 2014 2:18 AM
1 113
Post
Bug found: v8.2 Background Render fails if sequence name contains... by dekafilm
» Latest post by AndrewAction , Wed, Oct 22 2014 11:40 PM
7 193
Popular Post
Media Composer and "Yosemite" by GaryF
» Latest post by edsediting , Wed, Oct 22 2014 10:40 PM
1, 2
24 3,740
Popular Post
MC 7.04 and Blackmagic I/O broken Trim mode again! by Robert Goodman
» Latest post by dekafilm , Wed, Oct 22 2014 9:31 PM
1, 2 ... 8, 9, 10
143 21,212
Post
RX4 Connect and MC 7.0.4.1 problem by Hugh Livingston
» Latest post by Hugh Livingston , Wed, Oct 22 2014 9:16 PM
0 73
Popular Post
Quad split by Craig Harbour
» Latest post by Marianna , Wed, Oct 22 2014 5:59 PM
14 1,178
Post
CANCEL is default when adding transition by Shane Ross
» Latest post by Shane Ross , Wed, Oct 22 2014 5:43 PM
3 190
Popular Post
All exports have gamma shift MC 7.0.3 by Marc_89
» Latest post by Dave , Wed, Oct 22 2014 4:20 PM
6 1,345
Post
Copy/paste to script not correctly handling newlines by janusz
» Latest post by janusz , Wed, Oct 22 2014 2:26 PM
0 74
Post
Media Services Engine not conect in MC 8.2 by Carlos Escrig Legido
» Latest post by Carlos Escrig Legido , Wed, Oct 22 2014 11:19 AM
2 176
Post
No media can be written to any mounted drive by bibingeorge
» Latest post by bibingeorge , Wed, Oct 22 2014 11:17 AM
2 143
Write a New Post
Page 1 of 1012 (20233 items) 1 2 3 4 5 Next > ... Last »
More Options

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller