Media Composer | First Forum

This forum is for Media Composer | First released on June 29th 2017. This is the place to seek advice, help, mentoring from experienced editors. This forum is especially helpful if you are new to editing or just want to become part of the Avid community.
Write a New Post
Page 8 of 11 (207 items) « First ... < Previous 6 7 8 9 10 Next > ... Last »
Topics Replies Views
Popular Post
Second Monitor Problem with Media Composer on Laptop by teamhurst
» Latest post by DStone , Thu, Aug 31 2017 3:58 PM
8 856
Popular Post
tape ID / tape name columns in bins by mono
» Latest post by mono , Wed, Aug 30 2017 6:50 PM
2 551
Popular Post
8.9.1 seems to fix none of these by tommix
» Latest post by tommix , Tue, Aug 29 2017 2:54 AM
2 559
Popular Post
Exporting Highest Quality? by Tom Cook
» Latest post by AndrewAction , Sat, Aug 26 2017 9:31 PM
6 923
Popular Post
Application Manager won't initialize by Simon McGuire
» Latest post by Keith R , Thu, Aug 24 2017 11:11 PM
1, 2, 3, 4
51 8,740
Popular Post
Media Composer First - Exceptions by Keith R
» Latest post by Pilot , Tue, Aug 22 2017 8:27 PM
7 1,347
Popular Post
subclip never goes to bin by tommix
» Latest post by Marianna , Tue, Aug 22 2017 3:03 PM
8 884
Popular Post
MC ı First and EUCON by SvenIsak
» Latest post by SvenIsak , Sun, Aug 20 2017 1:04 PM
2 486
Popular Post
New video format in macOS 13 (High Sierra) by SvenIsak
» Latest post by Marianna , Fri, Aug 18 2017 6:06 PM
1 604
Popular Post
MCF crash on launch. Audio FX by Sidhu
» Latest post by TheNeil , Wed, Aug 16 2017 11:16 PM
1, 2
21 2,530
Popular Post
Problem with Title Tool by Raffaelle
» Latest post by AndrewAction , Wed, Aug 16 2017 11:04 PM
1 468
Popular Post
MCF fails to launch by dennisnv
» Latest post by TheNeil , Mon, Aug 14 2017 3:05 PM
1, 2
25 4,672
Popular Post
Dashboard doesn't load [SOLVED] by Toby
» Latest post by Toby , Mon, Aug 14 2017 1:25 AM
1, 2
20 2,635
Popular Post
Platform log-in denied - out of date with 8.9.0 [SOLVED] by Toby
» Latest post by Toby , Sun, Aug 13 2017 9:44 PM
1 455
Popular Post
MC First / MC Co-Install by agusting
» Latest post by RalphC , Fri, Aug 11 2017 5:03 PM
9 1,663
Popular Post
MCF Error: SYS_ERROR, OSErr: -5000 by Scott Silva
» Latest post by Mohd Azhar Ismail , Tue, Aug 8 2017 3:07 PM
3 673
Popular Post
Mac OS X 10.12.6 - Approved with v8.9.1 by AndrewAction
» Latest post by AndrewAction , Sat, Aug 5 2017 1:20 AM
0 638
Popular Post
Runtime error at launch by mikev
» Latest post by mikev , Thu, Aug 3 2017 2:55 AM
2 716
Popular Post
Activation failed - please try again by MCuser_manc
» Latest post by RalphC , Wed, Aug 2 2017 7:31 PM
3 1,123
Popular Post
Exception: AMPI subsystem error: Error Message Socket operation on... by ocdmusician.com
» Latest post by RalphC , Wed, Aug 2 2017 7:14 PM
1 467
Write a New Post
Page 8 of 11 (207 items) « First ... < Previous 6 7 8 9 10 Next > ... Last »
More Options

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller