Get Started Fast

Get assistance, answers, and insights and start editing now—join a community dedicated to the success of new users.
Forums Latest post Threads Posts
No unread posts Share Your Experience
Whether you’re new to the world of Media Composer or just returning after some time away, we’d like to hear from you.
Re: in mc using...
Mon, Mar 6 2017 1:33 PM
 
149 604
Write a New Post
Page 5 of 252 (5026 items) « First ... < Previous 3 4 5 6 7 Next > ... Last »
Topics Replies Views
Popular Post
Sony hires Nablet to maintain AMA Plugins to MC by cuervo
» Latest post by DStone , Wed, Jan 25 2017 2:15 AM
6 936
Popular Post
export QT video with mixedown audio channel by speran
» Latest post by speran , Tue, Jan 24 2017 7:41 AM
3 416
Popular Post
quick transition across multiples ? by Supermandan1
» Latest post by Supermandan1 , Mon, Jan 23 2017 12:46 AM
2 338
Popular Post
Setting up a microphone? by AnEditAssistant
» Latest post by Roger Shufflebottom , Wed, Jan 18 2017 1:24 PM
1 321
Popular Post
How to enable playback thru BlackMagic DeckLink 4K Extreme? by thordarson5000
» Latest post by Johnny Diesel , Wed, Jan 18 2017 4:44 AM
7 6,020
Popular Post
Media Composer 8.7.2 Now Available (16 Jan 2017) by AndrewAction
» Latest post by ripvanmarlowe , Tue, Jan 17 2017 4:47 PM
3 1,054
Popular Post
Problem with Monitor Display: Could MC Setting be my problem? by denniscasey
» Latest post by denniscasey , Fri, Jan 13 2017 7:28 PM
1 420
Popular Post
Legacy Hardware with the latest MC by Peter
» Latest post by Bruno M , Fri, Jan 13 2017 7:09 PM
3 479
Popular Post
Bin keeps going back to top when I make a subclip by SR555
» Latest post by SR555 , Thu, Jan 12 2017 2:44 AM
5 662
Popular Post
When to Duplicate and When to Copy Clips? by S.Clements
» Latest post by nigelad , Mon, Jan 9 2017 8:47 PM
4 2,362
Popular Post
How to put an effect on a source clip? by Supermandan1
» Latest post by Supermandan1 , Sun, Jan 8 2017 11:35 PM
1, 2
15 1,828
Popular Post
Avid MC 8.7 activation problems by gregNZ
» Latest post by RalphC , Fri, Jan 6 2017 1:45 PM
1 416
Popular Post
Media Composer 8.6.5 on OS10.12.1 can't out put to XDCAM U1-DRIVE by pete t.
» Latest post by mhoge , Thu, Jan 5 2017 3:47 PM
3 581
Popular Post
Erasing a gap in the sequence in the timeline by John
» Latest post by mjolnarn , Thu, Dec 22 2016 9:31 AM
6 1,280
Popular Post
Tracks out of sync by John
» Latest post by John , Thu, Dec 22 2016 5:05 AM
2 535
Popular Post
Dynamic Media Folder-BGS Question?? by cuervo
» Latest post by cuervo , Tue, Dec 20 2016 3:07 PM
8 1,158
Popular Post
Media Composer 8 quicktime export problems by Dave Mann
» Latest post by Fernando Sancho , Mon, Dec 19 2016 12:43 PM
8 4,384
Popular Post
I am totally confused by ILOK by Terrence MacArthur
» Latest post by conleec , Fri, Dec 16 2016 10:25 PM
2 641
Popular Post
HDR Workflows in Media Composer 8.5.1 by cuervo
» Latest post by ripvanmarlowe , Fri, Dec 16 2016 3:33 PM
2 1,463
Popular Post
Invalid attr kind. External Drive issue? Need help! by pipwatkins
» Latest post by smyers63 , Fri, Dec 16 2016 3:11 AM
14 1,330
Write a New Post
Page 5 of 252 (5026 items) « First ... < Previous 3 4 5 6 7 Next > ... Last »
More Options

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller