Get Started Fast

Get assistance, answers, and insights and start editing now—join a community dedicated to the success of new users.
Forums Latest post Threads Posts
No unread posts Share Your Experience
Whether you’re new to the world of Media Composer or just returning after some time away, we’d like to hear from you.
Re: MiDi Keyboard...
Tue, Sep 2 2014 4:59 PM
 
129 551
Write a New Post
Page 1 of 196 (3918 items) 1 2 3 4 5 Next > ... Last »
Announcements and FAQs
Announcement - post is pinned and allows no replies
Meet the Moderators
by Marianna , Thu, Jul 28 2011 8:45 PM
Announcement - post is pinned and allows no replies
Updated 2/2014 - Building Your MC or Symphony Suite
by Marianna , Thu, Jul 28 2011 9:55 PM
Announcement - post is pinned and allows no replies
Get Started with Pro Video Community
by Marianna , Thu, Jul 28 2011 9:05 PM
Announcement - post is pinned and allows no replies
Get Started w/ Media Composer or Symphony Option Trial
by Marianna , Thu, Jul 28 2011 9:24 PM
Announcement - post is pinned and allows no replies
MC & Symphony Doc's, Customer Training & PDF Files
by Marianna , Tue, Jun 5 2012 3:03 PM
Announcement - post is pinned and allows no replies
Getting Started for Students and Educators
by Marianna , Mon, Aug 1 2011 5:30 PM
Announcement - post is pinned and allows no replies
Getting Started with Customer Support
by Marianna , Fri, Jul 29 2011 2:56 PM
Topics Replies Views
Popular Post pinned
Updated 7/3/14: Get Started Fast w/Media Composer|Software License by Marianna
» Latest post by Marianna , Tue, Apr 29 2014 6:38 PM
0 2,045
Post
MC keeps quiting and Title Tool wont save titles by Juan Carlos Zaldivar
» Latest post by Juan Carlos Zaldivar , Thu, Sep 18 2014 4:48 AM
0 30
Post
Cant get trial version of media composer to load by william79
» Latest post by AidasZK , Wed, Sep 17 2014 6:30 PM
1 125
Post
Effects not rendering properly? by Alexander J Cockburn
» Latest post by Alexander J Cockburn , Wed, Sep 17 2014 4:09 PM
3 138
Post
MC7 and PT10 working together by Supermandan1
» Latest post by Supermandan1 , Tue, Sep 16 2014 9:39 PM
0 105
Post
Will Some Assist Me With Transfering Audio Clip to STRUCTURE by Glen Glen
» Latest post by AndrewAction , Sun, Sep 14 2014 11:55 PM
1 121
Post
Reverb by Supermandan1
» Latest post by Pat Horridge , Sat, Sep 13 2014 4:36 PM
1 124
Post
Why isn't the find tool working for me? by rachinc
» Latest post by rachinc , Sat, Sep 13 2014 3:24 PM
5 177
Post
Subclips Offline. Why can't I bring media online? by rachinc
» Latest post by Pat Horridge , Sat, Sep 13 2014 2:33 PM
1 132
Post
Unwanted r3d files showing up in media tools search by BoomRob
» Latest post by Pat Horridge , Sat, Sep 13 2014 11:02 AM
1 130
Popular Post
Confused [*-)] FRAME FLEX Subclipping with AutoSync doesnt work..... by aha_international
» Latest post by Jonno Woodford-Robinson , Fri, Sep 12 2014 8:45 AM
2 491
Popular Post
Avid Media Composer crashes while initializing Audio Plugins, prompts... by johnny vodka
» Latest post by Michael Wolf , Thu, Sep 11 2014 9:17 PM
5 681
Post
Cool [H] Background Rendering is in sight! by Pixel Monkey
» Latest post by Avid Users Ecuador , Thu, Sep 11 2014 3:29 PM
1 155
Write a New Post
Page 1 of 196 (3918 items) 1 2 3 4 5 Next > ... Last »
More Options

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller